1

I've tried all of the suggestions I could find from forums and Q&A sites (like this one), but I am still not able to live boot Ubuntu 14.04 from USB.

I am using a SanDisk Cruzer 32GB.

I have tried:

  1. Reformatting as FAT32
  2. Wiping and rebuilding the MBR
  3. Using several different tools including unetbootin and the built-in live USB creator
  4. Checking boot flags
  5. Recreating the partition table

Yes, my BIOS recognizes the drive. Yes, this drive can be booted from.

I have made a bootable USB drive at least 20 times in the past with the same drive without a problem. Any Ideas?

  • Please describe the problem. The application (live creator /unmetbootin) fails, or you can not boot ? What error message and what behavior ? Have you checked the md5 sum of the iso ? – Panther Apr 27 '14 at 18:08
  • @bodhi.zazen There are no errors until I try to boot at which point it says something like: "Boot failure, press any key to continue." – Andrew Apr 27 '14 at 18:17
  • Have you checked the disk image with md5sum? help.ubuntu.com/community/HowToMD5SUM – Nattgew Apr 28 '14 at 17:56
1

I've figured out my issue, hopefully it will help you, Andrew. In looking at the Partitioning options for the USB key, I see that there was an MBR and a GPT option. You have to ensure you are partitioning with MBR. GPT appears not to create a partition recognized by UEFI or legacy BIOS. I repartitioned, ensuring MBR was selected, reformated FAT32, and now have two USB keys that work, the Corsair Voyager 16GB and the SanDisk Cruizer Glide 32GB.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.