3

I have a UK keyboard. It works. But in the top right corner of my Gnome Shell screen I have a little "en1⌄" menu which offers me a choice of UK or US keyboards.

As I have no plans to move across the ocean, being constantly offered a foreign keyboard layout is not useful; it is screen junk.

So I went to Keyboard Layouts and removed the US layout, leaving just the UK one. The menu disappeared - great...but turns out that now it thought my keyboard had gone all American - press # and I'd get \!

Enable the US keyboard, and it goes UK again(!).

It's only annoying, but wondering if anyone can fix?

EDIT: Screenshots added:

Gnome's System Settings: Gnome System Settings

Region & Language

screenshot 1

screenshot 2

screenshot 3

2
2

You can try to edit the panel.js file located in the /usr/share/gnome-shell/js/ui/ directory.

Note: I have two keyboard layouts (Es , En). First I will create a backup of the file and comment the line 855 to remove the keyboard indicator in the gnome panel without removing a keyboard layout.

1) Open a Terminal window Ctrl+Alt+T and type:

  • sudo cp -p /usr/share/gnome-shell/js/ui/panel.js /usr/share/gnome-shell/js/ui/panel.js.bak
  • sudo nano -c /usr/share/gnome-shell/js/ui/panel.js

Comment or delete the line 855 (You can use the double slash "//" for single line comments)
'keyboard':imports.ui.status.keyboard.InputSourceIndicator,

To save the changes in nano.. Ctrl+O,Enter then Ctrl+X.

Before:

enter image description here

After:

enter image description here

Finally to see the changes you can logout login, restart the panel or reboot your machine.


Now if you neeed to change the Keyboard layout you can use the shortcut Ctrl+Space.

enter image description here

Important: Just in case ... remember you have the file panel.js.bak as a backup.

Hope this helps.

1
  • Great work-around, and well presented, too. Thanks. However I've decided I need it now because every time Gnome Shell crashes (yeah, so I do need it!) I have to use it to swap to US and then back to UK to get it working again. Turns out it's a massive bug that nobody knows how to fix... May 17 '14 at 9:42
0

Goto System Settings then Text Entry and uncheck the option Show current input source in menu bar. That's it.

1
  • Text Entry does not exist in Gnome Shell's System Settings (see screenshot that I've added to my Q) Apr 28 '14 at 8:17
0

The answer is that you cannot do this at the moment, due to known bugs.

I reported this bug and it's been merged as a symptom of a bigger one:

There is a monster bug about keyboard layouts in launchpad. Still basically unsolved; the interactions between gnome-control-center, input methods, KBD options and co& are a real nightmare.

The bug title is just one of the symptoms. The behavior reported here was commented somewhere... at least I think.

See https://bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/1218322

So while you can remove it, doing so does not fix the problem. Also, as the keyboard layout gets reset to US whenever Gnome Shell crashes and you can only remedy this by changing the layout back to US (the indicator does not register the reset) and then back to UK again, removing the indicator would not be convenient.

I thought there might be a setting somewhere, which is why I asked the question, but it turns out it's a bug.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.