9

Since a fresh install of Ubuntu 14.04 I'm loosing internet connection after a few minutes. I comes back after reboot or wakeup from standby. That seems to be a known issue with the Realtek RTL8188CE wireless driver. The same worked perfect with Ubuntu 12.04.

Here are the details:

uname -a

Linux annika-notebook 3.13.0-24-generic #46-Ubuntu SMP Thu Apr 10 19:11:08 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

lspci -nnk | grep -i net -A2

07:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter [10ec:8176] (rev 01)
    Subsystem: Realtek Semiconductor Co., Ltd. Device [10ec:9181]
    Kernel driver in use: rtl8192ce
08:00.0 Ethernet controller [0200]: Qualcomm Atheros AR8151 v2.0 Gigabit Ethernet [1969:1083] (rev c0)
    Subsystem: QUANTA Computer Inc Device [152d:0872]
    Kernel driver in use: atl1c

cat /etc/network/interfaces

# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

cat /etc/resolv.conf

# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 127.0.1.1

cat /etc/hosts

127.0.0.1   localhost
127.0.1.1   annika-notebook

# The following lines are desirable for IPv6 capable hosts
::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

ifconfig -a

eth0      Link encap:Ethernet  Hardware Adresse e8:9a:8f:ca:6d:92  
          UP BROADCAST MULTICAST  MTU:1500  Metrik:1
          RX-Pakete:0 Fehler:0 Verloren:0 Überläufe:0 Fenster:0
          TX-Pakete:0 Fehler:0 Verloren:0 Überläufe:0 Träger:0
          Kollisionen:0 Sendewarteschlangenlänge:1000 
          RX-Bytes:0 (0.0 B)  TX-Bytes:0 (0.0 B)

lo        Link encap:Lokale Schleife  
          inet Adresse:127.0.0.1  Maske:255.0.0.0
          inet6-Adresse: ::1/128 Gültigkeitsbereich:Maschine
          UP LOOPBACK RUNNING  MTU:65536  Metrik:1
          RX-Pakete:11699 Fehler:0 Verloren:0 Überläufe:0 Fenster:0
          TX-Pakete:11699 Fehler:0 Verloren:0 Überläufe:0 Träger:0
          Kollisionen:0 Sendewarteschlangenlänge:0 
          RX-Bytes:8044499 (8.0 MB)  TX-Bytes:8044499 (8.0 MB)

wlan0     Link encap:Ethernet  Hardware Adresse 9c:b7:0d:33:fa:cd  
          inet Adresse:192.168.1.37  Bcast:192.168.1.255  Maske:255.255.255.0
          inet6-Adresse: fe80::9eb7:dff:fe33:facd/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metrik:1
          RX-Pakete:351596 Fehler:0 Verloren:0 Überläufe:0 Fenster:0
          TX-Pakete:216953 Fehler:0 Verloren:0 Überläufe:0 Träger:0
          Kollisionen:0 Sendewarteschlangenlänge:1000 
          RX-Bytes:498072663 (498.0 MB)  TX-Bytes:23696977 (23.6 MB)

wlan0     IEEE 802.11bgn  ESSID:"UNTEN"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: 00:0F:66:E9:D0:A7   
          Bit Rate=18 Mb/s   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr=2347 B   Fragment thr:off
          Power Management:off
          Link Quality=60/70  Signal level=-50 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:135   Missed beacon:0

wlan0     IEEE 802.11bgn  ESSID:"UNTEN"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: 00:0F:66:E9:D0:A7   
          Bit Rate=18 Mb/s   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr=2347 B   Fragment thr:off
          Power Management:off
          Link Quality=60/70  Signal level=-50 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:135   Missed beacon:0

route -n

Kernel-IP-Routentabelle
Ziel            Router          Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.1.1     0.0.0.0         UG    0      0        0 wlan0
192.168.1.0     0.0.0.0         255.255.255.0   U     9      0        0 wlan0

cat /var/lib/NetworkManager/NetworkManager.state

[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true
WimaxEnabled=true

cat /etc/NetworkManager/NetworkManager.conf

[main]
plugins=ifupdown,keyfile,ofono
dns=dnsmasq

[ifupdown]
managed=false
# PCI device 0x1969:0x1083 (atl1c)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="e8:9a:8f:ca:6d:92", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"

cat /etc/udev/rules.d/70-persistent-net.rules | egrep -i 'device|sub' -A3

# PCI device 0x1969:0x1083 (atl1c)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="e8:9a:8f:ca:6d:92", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"

# PCI device 0x10ec:0x8176 (rtl8192ce)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="9c:b7:0d:33:fa:cd", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan0"
  • Mine started working much better after I upgraded to the latest stable kernel. – user287374 Jun 1 '14 at 12:45
2

Hm, cant say for sure, the freedomben driver actually worked for me...

so, if you're not sure how to, do the following (I'll avoid git, for simplicity);

goto: https://github.com/FreedomBen/rtl8188ce-linux-driver/tree/ubuntu-14.04

... and download the zip file (right-hand side)

... when downloaded, extract the .zip file and 'cd' into it.

finally run install.sh ($ sudo ./install.sh).

Instructions can also be found on git...

Hope it helps

  • cool thing! didn't improve the speed drops. – Blauhirn Jul 5 '16 at 15:25
2

I have the same card and was having the same issues. Try upgrading to the 3.13.0-32-generic kernel, turn the "n" band off on your router, and use channel 1.

The newer kernel was already there on my 14.04 LTS, just boot into Grub by holding the "shift" key during boot and then select the 3.13.0-32-generic kernel. Rebooting will select your old kernel if you have any issues. Just if it works, set the newer kernel to the default kernel to survive a reboot.

Now update the driver using the following commands in the terminal:

echo "options rtl8192ce swenc=1 ips=0" | sudo tee /etc/modprobe.d/rtl8192ce.conf
sudo modprobe -rfv rtl8192ce
sudo modprobe -v rtl8192ce

*kudos to Wildman for helping me fix my issues on this.

0

Open the terminal and run these commands in order:

sudo apt-get install linux-headers-generic build-essential git
git clone http://github.com/lwfinger/rtlwifi_new.git
cd rtlwifi_new
make
sudo make install
modprobe rtl8821ae # once booted ...just in case

protected by Community Jun 23 '17 at 4:36

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.