5

I updated to 14.04. My sound immediately transitioned from being normal to sounding extremely quiet, sounding like it was at 5% of max volume, though all my volumes were set properly. I tried lots of things to fix it by adjusting volumes, reloading ALSA, etc.

I then ran 'aplay -l' which output that I had an ALC892 sound card. I google'd issues with 14.04 and ALC892 and found a solution which said to modify

/etc/modprobe.d/alsa-base.conf

and add to the end of the file:

snd-hda-intel model=generic

It worked and fixed it! Now when I run 'aplay -l' it just reports my sound card as HDA Intel PCH.

My question is, why did this fix my sound?

3

I'm not a massive expert in Linux, but here's my theory:

Inserting the command block code:

snd-hda-intel model=generic

...tells us a few things by itself. Let's break it down a little.

The "snd-hda-intel" part obviously tells Alsa that the sound device header is an Intel-based unit. No brainer. However, the "model=generic" part is the interesting one.

"model=generic," to me at least, tells Alsa that we're looking for generic drivers of sorts for this Intel audio header. It's kind of like an override command so that Alsa looks exactly for the right stuff for the right hardware.

This recently became the issue for me the other day when I had to upgrade my computer from an old AMD FM2+ computer to a shiny new i3 - Alsa didn't immediately work with the new audio headers. That tells me that Alsa has a pre-defined library for more-than-generic audio devices. Therefore, specifying that you should use "snd-hda-intel model=generic" tells me that audio devices like the ALC892 need explicitly-stated libraries to work effectively, such as "generic," for all intent and purpose.

I'm not saying I know everything there is about the topic, as this is simply estimating from my own experience. I am aware the post is a bit aged, but I think an answer of some kind should at least be explained...somehow.

  • 2
    I can't fault your logic, but you might find this of interest. – Elder Geek Mar 13 '17 at 23:51

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.