18

This seems like one of the most-asked items around here, but the Ubuntu dev team has been making changes fast in this area, so recent information is important.

I'm on a macbook pro 9,2.

When I installed Ubuntu Saucy, I got the new and exciting mtrack driver for my touchpad. It seems to work well for all the basic functions and two and three finger gestures seem to be picked up by my applications, at least (ie firefox 3 button "back", scrolling). I would like to customize the gestures though, and maybe add one or two of my own to manage my workspaces/windows. I updated to 14.04 last night to see if multitouch support in the GUI was improved (it doesn't look like it).

  • I have tried touchegg, but it seems like it relied on utouch which no longer exists in 13 or 14. It can't detect anything from my touchpad, even when I recompiled unity without multitouch, per http://ineed.coffee/1068/os-x-like-multitouch-gestures-for-macbook-pro-running-ubuntu-12-10/ . Most of the doco I've seen on it assumes you're using synaptics, so maybe that's the problem.

  • I have tried ginn, but encountered the same problem - it can't detect any input from my trackpad gestures.

  • I have tried easystroke, but it wants me to have a "gesture button" which enables gestures. I just want to do them without a special button.

This is driving me crazy. I understand that if I switch to Ubuntu Gnome touchegg should "just work". But do I REALLY have to change my whole shell interface to configure mouse gestures? Does Unity REALLY hijack the entire multitouch stack without exposing any of it in a configuration tool?

I feel like this is so ridiculous I must be missing something obvious. Any advice would be welcome.

  • any updates on multi-touch gestures with Ubuntu 14.04/Unity? – jairo May 4 '14 at 1:47
  • 1
    If this issue affects you and you want it to change, register (if needed) and let the unity developers know here: bugs.launchpad.net/unity/+bug/842693 and while you are at it here (and in the bugs linked to there one of which is the above): bugs.launchpad.net/unity/+bug/1340846 The importance of this seems to be very low since the issue has been since 11.10 or something and is still on the current nightly build of 16.04!! However as long as the developers don't know that it bothers a lot of people it is not just their fault. – tortortor Mar 11 '16 at 20:42
2

On the latest ubuntu, all the advanced multi-touch only work from the touchscreen, not from the touchpad.

So what is left is:

  • scroll (two fingers drag up or down),
  • list of running software (3 fingers double tap)
  • launcher (4 fingers tap)

all the other advanced multitouch gestures are only available from the screen. I'm still puzzled by that design choice.

Touchégg seems to work with 14.04 (I'm on 14.10, can't confirm/deny) https://code.google.com/p/touchegg/

  • Your answer seems to be correct, and I am puzzled by this design choice as well – Alexander Mills Dec 3 '16 at 4:33
1

According to the Unity Gesture UI Guidelines only the "4 finger" and "1 finger edge" are hard-coded into Unity. I can attest to the fact that most gestures on Wacom tablets can be easily disabled without recompiling Unity (using xsetwacom), however the "4 finger" gesture that opens the dash (which is inadvertently triggered often by my knuckles while writing on the Wacom) is annoyingly persistent.

Update: Recompiling Unity to remove the offending code which pertains to the four finger touches was pretty painless and well outlined in another thread.

1

I have written a guide to do this. Basically, in order for this to work, you must use a forked syndaemon driver. You will also use a program called xswipe. Follow this link.

1

Actually, all of these features still function on the touchpad. The only thing they did was add support for touch screen laptops/monitors. When they did this though, most of the default multi-finger gestures were moved to the touch screen. So if you want them on the touchpad, then all you have to do is set up the shortcut and the command, similarly to that which you would do for a keyboard shortcut. (and yes, I know that this does work, I am currently using Ubuntu 15.04 Vivid Vervent.)

  • 1
    I revise my answer now that I read your question further, sorry. Yes, you need Synaptics for all of this to function properly. – John Hamilton Jan 6 '15 at 22:40
  • 1
    You don't need to comment your answer. Please click the edit-link below you answer to update it. – MadMike Jan 16 '15 at 7:49

protected by Community Mar 12 '16 at 4:24

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.