Hi I just installed the newest version of Ubuntu, 14, and now I need to install MySql Workbench.

I download the .deb package from mysql site but when I try to install it I obtain this error:

Preparing to unpack .../mysql-workbench-community-6.1.4-1ubu1310-amd64.deb ...
Unpacking mysql-workbench-community (6.1.4-1ubu1310) ...
dpkg:dependency problems prevent configuration of mysql-workbench-community:
 mysql-workbench-community depends to mysql-client; however:
  The mysql-client package didn't install.

dpkg: error processing package mysql-workbench-community (--install):
 dependency problems - leaving unconfigured
Processing triggers for gnome-menus (3.10.1-0ubuntu2) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu1) ...
Processing triggers for bamfdaemon (0.5.1+14.04.20140409-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for mime-support (3.54ubuntu1) ...
Processing triggers for shared-mime-info (1.2-0ubuntu3) ...
Processing triggers for hicolor-icon-theme (0.13-1) ...
Errors were encountered while processing:

I try to run sudo apt-get -f install and sudo apt-get update, I try to install manually dependecies but didn't work.

Can you help me?

Thank you


I ran: `dpkg --get-selections | grep mysql`

and I get this:

libdbd-mysql-perl               install
libmysqlclient18:amd64              install
mysql-client-5.6                install
mysql-client-core-5.6               install
mysql-common                    install
mysql-common-5.6                install
mysql-server-5.6                install
mysql-server-core-5.6               install
mysql-workbench-community           deinstall
  • 1
    You have to install mysql-client before. sudo apt-get install mysql-client – Hamed Kamrava Apr 27 '14 at 9:43
  • Yes I installed it before – Teo Apr 27 '14 at 9:45
  • But your error log says The mysql-client package didn't install. Make sure this package installed successfully. – Hamed Kamrava Apr 27 '14 at 9:47
  • I run this now: sudo apt-get install mysql-client-5.6 but I obtain: mysql-client-5.6 is already the newest version. – Teo Apr 27 '14 at 9:50

I solved in this way:

1) unistall mysql-server

2) delete all configuration about mysql-workbench

3) instead of use .tar.gz on mysql site, I install all by Software Center.

Now it works..

  • besides /usr/share/mysql-workbench, where else could I find config files? Still unable to install workbench with mysql 5.6 installed. – Dylan Pierce Aug 18 '15 at 19:05
  • Run a command like: sudo find / -name mysql-workbench – Teo Aug 24 '15 at 8:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.