7

I have just installed Ubuntu 14.04 and tried to type in Korean by adding the Korean language by using the language support and input method switcher. However, I am still unable to type in Korean. I have also installed ibus hangul, but I am unable to see any ibus settings or anything related to ibus in any settings. I have tried switching the language from the top right setting from EN to Ko and I still type in English.

So how can I type in Korean, did I miss a step or something? Any advice would be greatly appreciated.

10
  • Do you know Korean? The language support won't translate for you. Assuming you know korean, you may need a korean keyboard.
    – Elder Geek
    Apr 27, 2014 at 2:11
  • Yes, I know Korean. So do I need to get a physical Korean keyboard to type Korean in Ubuntu because I thought that you just need to install a software thing.
    – justauser
    Apr 27, 2014 at 2:32
  • What do you mean by "I can't"? Do you see squares instead of characters? It just types in English?
    – Alex
    Apr 27, 2014 at 2:52
  • Did you install Ubuntu while in Korea? Let me go through the steps that are supposed to work: Install the languages in language settings, then go to the text entry settings and add the input you want. If that input isn't in the list, then we have basically the same problem although I am trying to use Chinese...pls give us more info, this could be a bug.
    – RhZ
    Apr 27, 2014 at 3:46
  • 3
    It's the "Korean (Hangul)" option in "Text Entry" you want, not just "Korean". After having installed the Korean language from Language Support, you need to re-login before "Korean (Hangul)" shows up as an option in "Text Entry". Did you do that? help.ubuntu.com/14.04/ubuntu-help/keyboard-layouts.html Apr 27, 2014 at 6:19

5 Answers 5

9

In a terminal type

ibus-setup

click the input method tab, and add Korean - Hangul.

go to System Settings -> Text Entry and add Korean - Hangul

1
  • this should be the answer
    – jAckOdE
    Jan 3, 2015 at 8:01
5

After installing Ubuntu, go to language support. Choose Korean to add language.Then, restart the system and go to "text entry" and choose "korean (hangul)", not just "korean".

4

Ensure that the package ibus-hangul is installed. You can do it simply with the program synaptics, or you can do

dpkg -l | grep ibus-hangul

If you don't have it, well... install it (again, with synaptics or with the command line:

sudo apt-get install ibus-hangul

Then, in Unity (or Gnome), you should find the program "ibus preferences". On the top, there is a scrolling menu: "Select an input method". Click on it, select Korean, then click on the plus sign to add it. That should be it.

4

After installing Korean Language Support, you have to restart Ubuntu in order for Korean(Hangul) [with the little goryeo taeguk flag] to show up in the text entry list.

If you go to inputs before you restart, you'll see a Korean option, but it's not hangul. I'm not sure what it does, as it just types in English either way. You have to choose the one with the goryeo taeguk icon [red, blue, and yellow circular logo]

1

When you're using hangul you might need to type shift+space to switch to korean characters.

To fix this annoying default, look at the ibus preferences in the menu where you add languages to ibus ("Input Method" tab).

Select "Korean - Hangul". (after adding "Korean - Hangul" if you haven't already)

To the right there is a "Preferences" button. Click it.

Checkmark the box "start in hangul mode".

Now you don't need to use extra hot keys to switch to korean characters!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.