0

I am trying to mount a separate hard-disk automatically before startup, and for some reason fstab is failing me. It will not boot the partition on a separate disk at startup. The partition is question is in the last entry.

This is my present entry

# / was on /dev/sdb1 during installation
UUID=974b76b1-0d50-44af-9907-9d4a7eb5dafa /               ext4    errors=remount-ro 0       1
# swap was on /dev/sdc5 during installation
UUID=147dedf1-4f84-4c1f-87e9-662c51372e21 none            swap    sw              0       0

#data partition
UUID=a14cb5de-4a9f-44bb-a59f-63c2dedc4950 /mnt/Data ext4 uid=1000,gid=1000,umask=0022,sync,auto,rw 0 0

I am able to mount the device with sudo /dev/sdc6 /mnt/Data

I am using the disk as my data drive while the OS runs on an SSD. Any help is appreciated.

  • Is there anything helpful in dmesg? – Jos Apr 26 '14 at 22:07
  • @Jos '[ 4.928704] EXT4-fs (sdc6): Unrecognized mount option "uid=1000" or missing value' but id -u rewarp gives 1000. – Rewarp Apr 26 '14 at 22:21
  • As a workaround I added the mount command to /etc/rc.local which works rather neatly. But I still want to do it the "proper" way if possible. – Rewarp Apr 26 '14 at 22:24
0

Finally solved this issue by issuing the default options for fstab with some minor tweaks.

Instead of

UUID=a14cb5de-4a9f-44bb-a59f-63c2dedc4950 /mnt/Data ext4 uid=1000,gid=1000,umask=0022,sync,auto,rw 0 0

I instead went with the defaults with the exception of nosuid and nodev for suid and nodev

UUID=a14cb5de-4a9f-44bb-a59f-63c2dedc4950 /mnt/Data auto rw,nosuid,nodev,exec,auto,nouser,async 0 0

The 'dmesg' output did give a hint that it was a user issue. I guess the user isn't loaded yet into the system so that's why the gid wasn't recognised? Anyway, thanks Jos for the hint that led to me resolving the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.