1

After upgrading my Kubuntu to 14.04 from 12.04, I got extremely slow DNS lookup in Firefox and Thunderbird.

I have checked the communications with Wireshark. Launching e.g. http://vs.hu in Firefox (28), I got the following packets:

No. Time Source Destination Protocol Length Info 1 0.000000000 192.168.1.13 192.168.1.1 DNS 65 Standard query 0xb406 A vs.hu

No. Time Source Destination Protocol Length Info 2 0.013074000 192.168.1.1 192.168.1.13 DNS 82 Standard query response 0xb406 A 91.120.239.162

No. Time Source Destination Protocol Length Info 3 0.013363000 192.168.1.13 192.168.1.1 DNS 65 Standard query 0x7f30 AAAA vs.hu

No. Time Source Destination Protocol Length Info 4 0.014928000 192.168.1.1 192.168.1.13 DNS 110 Standard query response 0x7f30 PTR vs.hu

No. Time Source Destination Protocol Length Info 5 5.003951000 192.168.1.13 192.168.1.1 DNS 65 Standard query 0x1ff5 A vs.hu

No. Time Source Destination Protocol Length Info 6 5.019617000 192.168.1.1 192.168.1.13 DNS 82 Standard query response 0x1ff5 A 91.120.239.162

No. Time Source Destination Protocol Length Info 7 5.020167000 192.168.1.13 192.168.1.1 DNS 65 Standard query 0xc659 AAAA vs.hu

No. Time Source Destination Protocol Length Info 8 5.021866000 192.168.1.1 192.168.1.13 DNS 110 Standard query response 0xc659 PTR vs.hu

No. Time Source Destination Protocol Length Info 9 10.008493000 192.168.1.13 91.120.239.162 TCP 74 45348 > http [SYN] Seq=0 Win=29200 Len=0 MSS=1460 SACK_PERM=1 TSval=267003 TSecr=0 WS=128

It starts 1-1 query, IPV4 and IPV6, both servers reply. Then it starts this process again at 5th second. Finally only at 10th seconds starts reading data from server using TCP protocol. Using Chrome browser, there is no problem, however it uses MDNS protocol in the beginning of the communication. It cannot be a hardware (driver) problem. Same problem exists both with wired and wireless LAN. Moreover I started my 2nd computer (contains Kubuntu 12.04) with 14.04 LiveCD, and this problem also emerged there immediately.

I have run a similar test on my 2nd computer with Kubuntu 12.04, where there is no problem with DNS lookups in Firefox (28). Strange, but I do not see the IPV6 query there among the packets, no repeated queries, and no delays. Checking IPV6, it is not disabled there.

By the way, ping and dig reply almost immediately on 14.04.

Does anybody know what is going on? Where are these 5 seconds delays from? Perhaps my router or the Mozilla products hate 14.04? :)

  • I would guess that something is wrong with the DNS server at 192.168.1.1. These are not the responses I get from a normally functioning DNS resolver. If that is a home router, try rebooting it or updating its firmware. – Michael Hampton Apr 27 '14 at 17:56
1

Try to change dns to 8.8.8.8 and 8.8.4.4. This is a google dns or you can put your ISP dns. I guess that on ip 192.168.1.1 your router.

  • Thanks, it did really helped the speed of the DNS lookups in Firefox/Thunderbird. I have set my ISP DNS server addresses to the network manager, under the IPV4 DNS addresses. As for 192.168.1.1, it is the address of my router. I also checked the settings there. As far as I know the ISP DNS servers should be listed there, but those fields were empty. However despite I have filled those fields there, without the afore-mentioned network manager setting, it did not work. I'm still confused why my notebook (12.04) works without this aid, but I think I will never find this out. – brazso Apr 30 '14 at 14:02
1

Not sure it helps but I noticed dns AAAA queries (IPv6) to my router waiting long time to answer. My local net is IPv4. So in network connections configuration I put "disable" in IPv6 settings and it seemed to solve.

0

In my case disabling the avahi-daemon on my (DNS) server fixed the problem.

time dig www.outlook.com went from 1.5 seconds to 0.03 seconds on my laptop (running Ubuntu 14.04)

0

To disable IPv6 DNS lookup in Firefox just do the following:

  1. go to "about:config" page in Firefox
  2. find "network.dns.disableIPv6" key and set it to "true"

Rationale: It seems that Mozilla Firefox tries DNS lookup with IPv6 priority, which sometimes is unsupported by DNS server and cause few-seconds delay every time you open new page.

  • This seems like overkill for dealing with an old broken home router. – Michael Hampton Feb 28 '17 at 21:09
  • @MichaelHampton I don't get it - why do you mention "old broken home router" while the core problem here is Mozilla web apps: Firefox and Thunderbird? At some point in time Mozilla turned IPv6 on by default and suddenly "the internet slew down" - and that's exactly what brazso described. According to my research disabling IPv6 in Mozilla web apps is the best solution for that. – dimril Mar 2 '17 at 8:18
  • You haven't done enough research then. "Disabling IPv6" just avoids the problem, it doesn't actually fix it. The reason I mention old broken home routers is that this is one of the common places where the real problem lies (and appeared to be the case in the original question). – Michael Hampton Mar 2 '17 at 18:26
  • I don't use old router so maybe that's why I focused on another solution. I admit it's not the core-problem-solution, but disabling IPv6 is good enough alternative for me so I'll just leave that answer be. – dimril Mar 3 '17 at 21:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.