Today when I started Ubuntu, it didn't start lightdm, showing a black screen. I changed to console Ctrl-Alt-F1 and tried to start lightdm manually

sudo start lightdm

It threw me to the graphic console (Ctrl-Alt-F7) and showed the same black screen. Moreover, it looks like it starts, the console returned the number of process,

lightdm start/running, process 3616

However, after

sudo stop lightdm

I got

stop: unknown instance

Then I started gdm

sudo start gdm

and gdm started normal. So, the problem in lightdm.

To solve the problem I tried to purge lightdm and reinstall it

sudo apt-get purge lightdm
sudo apt-get install lightdm


sudo apt-get install --reinstall lightdm

The both ways didn't help.

Now I use gdm, but wants to restore lightdm if it is possible.

Thank you all for you help!

PS: I didn't install recently any additional driver (and haven't NVidia card at all).

PPS: Some additional information

$ sudo start lightdm
lightdm start/running, process 2466
$ dmesg | grep lightdm
[   18.284992] init: lightdm main process (1446) killed by TERM signal
[   57.691273] init: lightdm main process (2466) terminated with status 1

$ sudo start lightdm
lightdm start/running, process 8140
$ sudo cat /var/log/lightdm/lightdm.log 
[+0.00s] DEBUG: Logging to /var/log/lightdm/lightdm.log
[+0.00s] DEBUG: Starting Light Display Manager 1.2.3, UID=0 PID=8140
[+0.00s] DEBUG: Loading configuration from /etc/lightdm/lightdm.conf
[+0.00s] DEBUG: Using D-Bus name org.freedesktop.DisplayManager
[+0.00s] DEBUG: Registered seat module xlocal
[+0.00s] DEBUG: Registered seat module xremote
[+0.00s] DEBUG: Adding default seat
[+0.00s] DEBUG: Starting seat
[+0.00s] DEBUG: Starting new display for automatic login as user stas
[+0.00s] DEBUG: Starting local X display
[+0.00s] DEBUG: Using VT 7
[+0.00s] DEBUG: Activating VT 7
[+0.01s] DEBUG: Logging to /var/log/lightdm/x-0.log
[+0.01s] DEBUG: Writing X server authority to /var/run/lightdm/root/:0
[+0.01s] DEBUG: Launching X Server
[+0.01s] DEBUG: Launching process 8145: /usr/bin/X :0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
[+0.01s] DEBUG: Waiting for ready signal from X server :0
[+0.01s] DEBUG: Acquired bus name org.freedesktop.DisplayManager
[+0.01s] DEBUG: Registering seat with bus path /org/freedesktop/DisplayManager/Seat0
[+0.03s] DEBUG: Process 8145 exited with return value 1
[+0.03s] DEBUG: X server stopped
[+0.03s] DEBUG: Removing X server authority /var/run/lightdm/root/:0
[+0.03s] DEBUG: Releasing VT 7
[+0.03s] DEBUG: Display server stopped
[+0.03s] DEBUG: Stopping display
[+0.03s] DEBUG: Display stopped
[+0.03s] DEBUG: Stopping X local seat, failed to start a display
[+0.03s] DEBUG: Stopping seat
[+0.03s] DEBUG: Seat stopped
[+0.03s] DEBUG: Required seat has stopped
[+0.03s] DEBUG: Stopping display manager
[+0.03s] DEBUG: Display manager stopped
[+0.03s] DEBUG: Stopping daemon
[+0.03s] DEBUG: Exiting with return value 1

$ sudo cat x-0.log
X: cannot stat /etc/X11/X (No such file or directory), aborting.
  • Can you check the lightdm log in /var/log/lightdm?
    – Nattgew
    Apr 28, 2014 at 16:37
  • Thank you. I've added the output of cat /var/log/lightdm/lightdm.log.
    – Chaosor
    Apr 28, 2014 at 19:33
  • 1
    Try looking at /var/log/Xorg.0.log to see why X is quitting.
    – Nattgew
    Apr 28, 2014 at 19:36
  • I'm not sure, but it looks like nothng added to /var/log/Xorg.0.log. I've done the following commands sudo cat /var/log/Xorg.0.log > 1.log sudo start lightdm sudo cat /var/log/Xorg.0.log > 2.log The files 1.log and 2.log are identical. What have I done wrong?
    – Chaosor
    Apr 29, 2014 at 13:27

1 Answer 1


try to press CTRL + ALT + F1 then:

sudo /etc/init.d/gdm stop (for Gnome)

sudo /etc/init.d/lightdm stop (for Unity)

sudo dpkg-reconfigure xserver-xorg

if you wish to backup X so not to worry:

sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.backup

after all of this start X display:

sudo /etc/init.d/gdm start (for Gnome)

sudo /etc/init.d/lightdm start (for Unity)
  • Thank you very much! lightdm starts as normal.
    – Chaosor
    Apr 29, 2014 at 14:04
  • you're welcome, good luck!
    – JoKeR
    Apr 29, 2014 at 14:05
  • dpkg-query: package "xserver-org" is not installed and no information is available
    – Cerin
    Dec 14, 2015 at 17:37
  • 1
    it's xserver-xorg package not xserver-org and what is your comment about exactly? what are you trying to do and what is your distro version?
    – JoKeR
    Dec 17, 2015 at 1:05
  • dpkg-query: package "xserver-xorg" is not installed.
    – Kaz
    Dec 2, 2016 at 2:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.