12

Hopefully I'm not violating any rules by opening new topic for the issue I've encountered. Trust me, I've tried browsing all over askubuntu and bunch of other sites, but none of offered solutions have worked for me so far - hopefully you guys can help me solve the problem.

Earlier today I ran upgrade of my Ubuntu server to 14.04:

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 14.04 LTS
Release:        14.04
Codename:       trusty

I'm having the following problem:

E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem. 

If I run the command, its gets stuck at: Found kernel: /memtest86+.bin

Please advise how to proceed (I've tried multiple solutions including update-grub, and plenty others, but none worked).

$ sudo dpkg --configure -a
Processing triggers for initramfs-tools (0.103ubuntu4) ...
update-initramfs: Generating /boot/initrd.img-3.13.0-24-generic
Setting up mdadm (3.2.5-5ubuntu4) ...
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
dpkg: error processing package mdadm (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 mdadm

After restarting my pc and running sudo dpkg --configure -a, I'm back to the original issue:

Setting up mdadm (3.2.5-5ubuntu4) ...
 Removing any system startup links for /etc/init.d/mdadm-raid ...
update-initramfs: deferring update (trigger activated)
update-grub is /usr/sbin/update-grub
Searching for GRUB installation directory ... found: /boot/grub
Searching for default file ... found: /boot/grub/default
Testing for an existing GRUB menu.lst file ... found: /boot/grub/menu.lst
Searching for splash image ... none found, skipping ...
Found kernel: /vmlinuz-3.13.0-24-generic
Found kernel: /vmlinuz-3.2.0-61-generic
Found kernel: /vmlinuz-3.2.0-48-generic
Found kernel: /vmlinuz-3.2.0-24-generic
Found kernel: /vmlinuz-3.0.0-12-server
Found kernel: /vmlinuz-2.6.28-11-server
Found kernel: /vmlinuz-2.6.27-14-server
Found kernel: /vmlinuz-2.6.24-24-server
Found kernel: /vmlinuz-2.6.22-16-server
Found kernel: /vmlinuz-2.6.22-14-server
Found kernel: /memtest86+.bin

Uname -r returns

3.13.0-24-generic

After a lot of trouble, solved by dpkg --audit and then dpkg --configure <packagename> for packages listed

  • post the output of sudo dpkg --configure -a command. – Avinash Raj Apr 27 '14 at 2:22
  • comment edited per request – ftv3 Apr 27 '14 at 6:56
  • please post the above comment in your question. – Avinash Raj Apr 27 '14 at 6:57
  • restart you pc and then try sudo dpkg --configure -a – Avinash Raj Apr 27 '14 at 7:00
  • post the output of uname -r – Avinash Raj Apr 27 '14 at 7:07
19

This problem can happen in the case of Hyper-V virtualization (Happened to me today).

In this case the answer is to disable OS-probbing in grub by opening the configuration file :

sudo nano /etc/default/grub

And adding the line :

GRUB_DISABLE_OS_PROBER=true

After saving your changes to /etc/default/grub, rebuild grub (running on Windows 10 Hyper-V with Ubuntu 15.04 VM):

sudo update-grub

and then apt-get update or whatev:

sudo apt-get update
| improve this answer | |
  • @SalizarMarxx: Please don't leave "thank you" comments. Instead, vote for the answer if you like it. – David Foerster Jan 22 '16 at 15:12
  • Had the same problem on KVM, this solved the problem. – ortang Mar 9 '16 at 9:59
  • Had the same problem with an OpenStack VM, the solution worked nicely there as well. – Laryx Decidua Feb 23 '17 at 15:34
  • Why didn't grub developer just add timeout for os probing which would print this advice?.. – d9k Apr 15 at 21:56
4

After a lot of trouble, solved by

dpkg --audit 
# and then 
dpkg --configure
# for packages listed 
| improve this answer | |
3

My issue was that I had Ubuntu installed on a Hyper-V VM and I had Enable Dynamic Memory checked (which is default). As soon as I turned it off I no longer had the issue.

| improve this answer | |
  • 1
    Welcome to Ask Ubuntu! I recommend editing this answer to expand it with specific details about how to do this. (See also How do I write a good answer? for general advice about what sorts of answers are considered most valuable on Ask Ubuntu.) – David Foerster Nov 15 '15 at 10:43
0

I had the same issue with Ubuntu 14.04, which was upgraded from much earlier version (like Ubuntu 10.04).

Note: This is not a general solution, this is what worked for me.

The solution to this problem was to update grub from 0.97 to 2.

Details:

dpkg --audit

Showed a problem with mdadm, it cannot update with grub 0.97.

Here is the bug report: https://bugs.launchpad.net/ubuntu/+source/mdadm/+bug/1285312

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.