I've replaced my HDD by a SDD on my Zenbook Prime and am trying to install only Ubuntu 14.04. Before, I installed Ubuntu on the HDD which was already containing Windows 7, and everything worked great. I've made a GTP partition table on my SSD and created 3 partitions, a boot efi one, / and /home. When I boot, I can see grub but then after grub is complaining that it cannot find the disk by uuid. Boot-repair doesn't work. I've tried installing letting Ubuntu do the partitionning, same problem. I've tried disabling secure boot (which is named "anti-theft in my BIOS...) and installed in legacy mode, same problem too.

/dev/sdb is my live Ubuntu on an USB key.

Here is boot-repair log: http://paste.ubuntu.com/7338302/ idea why my disk is not found?


Edit: I've changed the GPT table to a MBR (msdos in parted) one and created 2 partitions: / and /home. The problem is still the same, it cannot find the disk by uuid. I've launched boot-repair, and this time, it worked, but the problem is still here. Here is the new pastebin: http://paste.ubuntu.com/7340850/

  • Found this clue in your boot-repair log: WARNING: GPT (GUID Partition Table) detected on '/dev/sda'! The util fdisk doesn't support GPT. Use GNU Parted. – Elder Geek Apr 26 '14 at 16:05
  • Boot repair doesn't work with GPT tables. – Elder Geek Apr 26 '14 at 16:09
  • It seems that it works with GPT tables, it's just that when it's trying to display a brief of what's going on, it uses fdisk and parted, but fdisk doesn't manage GPT tables. – groug Apr 27 '14 at 10:24
  • Perhaps I should have said "I've never been able to successfully repair a GPT installation with Boot Repair." – Elder Geek Apr 27 '14 at 13:49

I've solved my problem, even though I'm not satisfied with it:

Typing in "exit" in rescue shell... launched my Ubuntu partition. So I added "rootdelay=90" in grub command-line, and after ~45s, grub is launching Ubuntu.

45s is "unacceptable" for me, since it's a laptop with a SSD. I will try to boot the partition other than with the UUID.

  • First click on Advanced option in Boot-repair(not Recommended Repair)

  • Because you installed Ubuntu in UEFI mode, you have to give the partition where EFI files are located. In your case it's /dev/sda1.

  • Then run it.

  • Thanks. I tried to do that, in Advanced option, Boot-repair already found that EFI files were in /dev/sda1. – groug Apr 27 '14 at 10:23
  • Then proceed bootrepair. – Avinash Raj Apr 27 '14 at 10:57
  • Of course I did that :) But boot-repair failed: it told me to copy/paste some lines in a terminal, then some other lines, then told me that it failed to repair the boot. Since then I've changed my partition table (see my edit) but still no chance. – groug Apr 27 '14 at 11:01
  • Did you copy and paste the commands on terminal? If yes then post its output. – Avinash Raj Apr 27 '14 at 11:07
  • Yes. When I launched Boot-repair, I indeed launched Boot-repair. When it told me to copy/paste commands in a terminal, I did copy/paste commands in a terminal. If I'm posting here, it's because despite all that, grub is still failing to boot my Ubuntu partition. As for the commands, I'm sorry, I didn't save them. Thanks anyway. – groug Apr 27 '14 at 11:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.