6

The resolution of my lubuntu is 640x480 and I can not change it. There's no more options in the screen definitions.

This is my (horrible) graphic card:

01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 771/671 PCIE VGA Display Adapter (rev 10)

And this is what I got when I run the xrandr command:

xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 640 x 480, maximum 640 x 480
default connected primary 640x480+0+0 0mm x 0mm
   640x480        73.0* 
  800x600_60.00 (0x198)   38.2MHz
        h: width   800 start  832 end  912 total 1024 skew    0 clock   37.4KHz
        v: height  600 start  603 end  607 total  624           clock   59.9Hz
  2048x1536_60.00 (0x1da)  267.2MHz
        h: width  2048 start 2208 end 2424 total 2800 skew    0 clock   95.4KHz
        v: height 1536 start 1539 end 1543 total 1592           clock   60.0Hz
  1024x728_60.00 (0x1dc)   63.5MHz
        h: width  1024 start 1072 end 1176 total 1328 skew    0 clock   47.8KHz
        v: height  768 start  771 end  775 total  798           clock   59.9Hz
  1024x768_60.00 (0x1dd)   63.5MHz
        h: width  1024 start 1072 end 1176 total 1328 skew    0 clock   47.8KHz
        v: height  768 start  771 end  775 total  798           clock   59.9Hz

So, I want to have a 1024x768 resolution in this computer and I can't do nothing in this moment. I'm a newbie in Linux and for that reason I need some help. I tried to follow some steps that I saw in some topics but nothing happens.

9

Yes, it's not the best graphics card ever seen, but it can do 1024x768 in Lubuntu 14.04 all the same, if you force the machine to use the vesa driver.

Create a file /usr/share/X11/xorg.conf.d/use-vesa.conf with the following content:

Section "Device"
  Identifier "Configured Video Device"
  Driver "vesa"
EndSection

And that's all. Reboot, and you should have your resolution.

The file can be created with any text editor - if you're not comfortable with the terminal, you'd probably want to use something graphical like leafpad. However, you'd need to be root to have write access to the place where the file is needed.

So, open up a terminal (CTRL + Alt + t) and type "sudo leafpad". You need to enter your password there. I presume you're doing this as the default user so sudo should work and the editor window will open.

Then you can copy & paste the required text into the file and save it to the given location (/usr/share/X11/xorg.conf.d/). The name "use-vesa.conf" is arbitrary, you could also call it "whatever.conf", as long as the .conf bit is in the filename, and the file is saved in the right place, it will work.

Please check whether it works for you.

  • I'm really a noob here. So, I don't know how to create that file. :/ I tried this "sudo Xorg -configure" but then it showed an error. – user274585 May 8 '14 at 19:22
  • Same solution works fine here on my old Asus L3000D with SiS 65x/M650/740PCI/AGP graphics card. Thanks a lot. – Mrmfldmn Jun 19 '16 at 17:08
  • You're an amazing genius! This also works on an old (circa 2005) Acer Aspire 5000 running Ubuntu 16.04.3 (I'm about to call xubuntu-desktop as shown here to speed it up: askubuntu.com/a/64242/327339), with a SiS M760GX video card! Note that this card supports 1024 x 768 OR 1280 x 800 resolution. With your solution, I only get 1024 x 768 or 800 x 600. Any idea how to get 1280 x 800 instead? – Gabriel Staples Aug 28 '17 at 0:31
  • I've now got 1280x768 working! (which is even better than the 1024 x 768 achievable by using your answer), using this xorg.conf file posted in my question here (askubuntu.com/questions/952001/…). However, as my question states, I'm still trying to get 1280x800. 1280x768 is definitely better than 1024x768, however, but still not quite right. – Gabriel Staples Sep 1 '17 at 18:19
0

Create and use the /etc/X11/xorg.conf file shown in my question here: Cannot get resolution of 1280x800 on my "SiS M760GX" video card

The above solution allows resolutions of 1280x768, 1024x768, 800x600, or 640x480, thereby producing a better result than simply using the xorg.conf file below:

Section "Device"
  Identifier "Configured Video Device"
  Driver "vesa"
EndSection

protected by Community May 15 '14 at 0:28

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.