Command line shows ubuntu version as 14.04 while GUI shows 13.10.

I was upgrading my system yesterday from 12.04 to 14.04. When around 60-65% updates were installed, I had to shut down the system. When I restarted the system in the morning, the system booted fine but now it shows the above problem as shown here and here.

I tried the standard methods listed here and here.

This is output of sudo apt-get update. It clearly shows that updates are being made from 'trusty'. I tried to upgrade to 14.04 (Assuming I was on 13.10) using sudo update-manager -d But I got message saying "Software is up to date".

Can someone explain me how do I fix it. Also how come system recovered from the failed update?

Also the system now takes a lot of time to boot and it has one other minor issue. When I login in into the system, I get a glitch as shown in this video. This is just after I enter the password. Is it related to the issue I mentioned above or is it something else?


I think you have similar case to mine. As Ubuntu forked gnome-control-center, you may have both already installed after upgrade.

  • Open terminal, run unity-control-center → Details

    You should see 14.04 Logo

  • Open terminal, run gnome-control-center → Details

    You may see 13.10 Logo, like mine (I think someone forget to update it as it's not important, fresh Ubuntu install has only unity-control-center)

    To check run:

    xdg-open /usr/share/gnome-control-center/ui/UbuntuLogo.png
    xdg-open /usr/share/unity-control-center/ui/UbuntuLogo.png

I think it's just matter of logo image, no relation to upgrade or graphic glitch. This is related bug report lp bug#1281155 "About this Computer" shows 13.10 instead of 14.04

Now for resuming upgrade; I believe that How do I resume a release upgrade/update? will fix broken apt/dpkg status by resuming interrupted installation for only marked packages. So it does not really resume upgrade process.

If you notice that some old application are missing, this happened to me once then I installed all remaining applications by selecting them manually. (one by one)

Well, This is untested method neither I can prove it will not produce more problems.

  1. ubiquity uses apt-clone for upgrade process. As upgrade process was interrupted, ubiquity leaves its backup.


    (sudo updatedb; locate apt-clone, if you can't find it)

  2. Open apt-clone-state-ubuntu.tar.gz and verify ./etc/apt/sources.list is for trusty

  3. Install apt-clone

    sudo apt-get install apt-clone
  4. Restore backup using apt-clone

    sudo apt-clone restore /ubiquity-apt-clone/apt-clone-state-ubuntu.tar.gz
| improve this answer | |
  • Hmm. Could you add answer to remaining part of the question as well? – Shagun Sodhani May 3 '14 at 12:05
  • @Shagun, The answer you mention seems to work How do I resume a release upgrade/update?. Do you miss any previously installed application from the old system (Ubuntu 12.04)? – user.dz May 3 '14 at 12:28
  • 1
    No the working is mostly smooth other than the glitch I mentioned before – Shagun Sodhani May 6 '14 at 1:54
  • @Shagun, then glitch is something else, you could post a separate question for it. – user.dz May 6 '14 at 8:31
  • Yeah I agree. Anyways right now I am not marking this answer as accepetd in case some other answers may come up. Will mark it as accepeted answer before bounty duration gets over. Thanks a lot :) – Shagun Sodhani May 6 '14 at 8:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.