4

Ran current Ubuntu off USB, needed to enable "Broadcom 802.11 Linux STA wireless driver ..." by clicking Apply Changes in Additional Drivers. Having done that was able to connect to wifi without problem.

Whilst connected, I "Installed" Ubuntu on my HP Mini 110, cleaning everything off the drive. Updates were downloaded and everything was peachy. Prompted to Reboot, I did so and encountered again the need to Apply Changes to get the wireless working.

But now, clicking on Apply Changes does nothing but reset the button to "Do not use this device". I cannot enable the Broadcom driver and, of course, cannot connect to wifi.

In summary: works fine when booted from USB; doesn't work when booted from installed Ubuntu.

Thx.

3 Answers 3

7

This was the same case for me, but the drivers that worked on the bootable USB are still on the USB. If you first open the bootable USB in a file explorer and then search with CTRL+F for dkms and install that .deb file, and then search for bcmwl and install that .deb,

Then your card will work again.

1
  • 1
    This is the right answer if a wired connection is not an option. Dec 23, 2015 at 20:52
2

First, go to additional drivers, the the tab marked "Ubuntu Software". Check the box marked "Proprietary Drivers for Devices". Then enter into a terminal:

sudo apt-get update
sudo apt-get install bcmwl-kernel-source

Your wifi should then be enabled, if not go back to additional drivers and try to enable your device again.

3
  • No joy. Lots of "Err" and "Failed to fetch". Need computer have 'net access to "get updates"? Should I run it from the functioning USB boot? Or from a wired connection (which is difficult to get where I am)? Thx
    – user274531
    Apr 28, 2014 at 3:13
  • I also got this message: The following packages have unmet dependencies: bcmwl-kernel-source : Depends: dkms but it is not installable E. Unable to correct problems, you have held broken packages.
    – user274531
    Apr 28, 2014 at 3:46
  • Success! Hooked up a wired connection - which was no problem - followed the suggestion provided here (twice ...) and the Broadcom driver was installable and wireless connection now works. Thx.
    – user274531
    May 1, 2014 at 10:29
0

Got the same issue with Ubuntu 16.04 Live CD. The WiFi hardware is detected and the wifi driver is included in the USB installer. If the system is installed to hard drive, Ubuntu should be able to install the WiFi driver.

As answer the answer submitted by Pigeon indicates, you should manually install the WiFi driver "bcmwl-kernel-source" to fix the issue.

lspci|grep -i network
04:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01)

Once you get the WiFi fixed, use the following two line to upgrade WiFi driver:

sudo apt remove broadcom-sta-dkms bcmwl-kernel-source   
sudo apt install firmware-b43-installer

reboot

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .