I'm new to Ubuntu, I recently installed 12.04.4 LTS.

My display is not recognized by Ubuntu.

Display: Kent Modular Electronics (KME) 29LR1901A51UN/1 connected via RGBHV BNC connectors.

Video card: Nvidia GeForce 7600 GT

Under windows I'm using 1280x1024.

I tried different drivers using 'Additional drivers (jockey-kde / jockey-gtk), right now using nvidia_304.116 via jockey-gtk: 'This driver is activated but not currently in use.' Trying different drivers doesn't yield different resolutions, and in Displays my screen doesn't get recognized. Display Unknown.

Via https://wiki.ubuntu.com/X/Config/Resolution I tried 'Adding undetected resolutions'.

$ cvt 1280 1024

# 1280x1024 59.89 Hz (CVT 1.31M4) hsync: 63.67 kHz; pclk: 109.00 MHz
Modeline "1280x1024_60.00"  109.00  1280 1368 1496 1712  1024 1027 1034 1063 -hsync +vsync

after which

$ xrandr --newmode "1280x1024_60.00"  109.00  1280 1368 1496 1712  1024 1027 1034 1063 -hsync +vsync

This will add the mode to the list, but as TV-0 disconnected. I'm not able to use the mode.

Screen 0: minimum 8 x 8, current 1024 x 768, maximum 4096 x 4096
VGA-0 connected primary 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768       60.0*+
   1360x768       60.0     59.8  
   1152x864       60.0  
   800x600        72.2     60.3     56.2  
   680x384        60.0     59.8  
   640x480        59.9  
   576x432        60.1  
   512x384        60.0  
   400x300        72.2     60.3     56.3  
   320x240        60.1  
TV-0 disconnected (normal left inverted right x axis y axis)
  1280x1024_60.00 (0x26c)  109.0MHz
    h: width  1280 start 1368 end 1496 total 1712 skew    0 clock   63.7KHz
    v: height 1024 start 1027 end 1034 total 1063           clock   59.9Hz

From here I don't know what I'm supposed to do. Having done this doens't change anything yet. After rebooting this TV-0 mode is lost.

Trying to add the mode:

$ xrandr --addmode TV-0 1280x1024_60.00
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  18 (RRAddOutputMode)
  Serial number of failed request:  25
  Current serial number in output stream:  26

Is this wrong?

Installed inxi:

inxi -G
Graphics:  Card: NVIDIA NV44 [GeForce 6200 LE] 
           X.Org: 1.14.5 drivers: nvidia (unloaded: fbdev,vesa,nouveau) Resolution:     [email protected] 
           GLX Renderer: GeForce 6200 LE/PCIe/SSE2 GLX Version: 2.1.2 NVIDIA 304.116
  • What mode? What do you actually see? Who gives the "'This driver is activated but not currently in use." message? What's TV-0? Please edit your question and clarify. Also add the output of running xrandr in the terminal.
    – terdon
    Apr 26, 2014 at 12:12
  • Edited. I don't know what TV-0 is. This is what my mode is added to after running cvt 1280 1024 60.
    – user274519
    Apr 26, 2014 at 12:44
  • Thanks for the edit. How many displays do you have? It looks like you have just one connected and that is using a VGA cable. Is that correct?
    – terdon
    Apr 26, 2014 at 12:49
  • I'm using one display connected via RGBHV - BNC connectors to VGA, yes.
    – user274519
    Apr 26, 2014 at 12:58
  • Please give us more information. How exactly did you add this resolution? What was the exact command you used? Have you restarted since installing the nvidia driver? What do you actually see right now? The display is recognized, is the problem that it has the wrong resolution?
    – terdon
    Apr 26, 2014 at 13:01

2 Answers 2


Removed all additional drivers like this.

Added the mode like this:

$ cvt 1280 1024 60

$ xrandr --newmode "1280x1024_60.00"  109.00  1280 1368 1496 1712  1024 1027 1034 1063 -hsync +vsync 

$ xrandr --addmode VGA-1 1280x1024_60.00

Display jumped to correct resolution after adding the mode to VGA-1.

$ xrandr
Screen 0: minimum 320 x 200, current 1280 x 1024, maximum 4096 x 4096
VGA-1 connected primary 1280x1024+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768       60.0  
   800x600        60.3     56.2  
   848x480        60.0  
   640x480        59.9  
   1280x1024_60.00   59.9* 
TV-1 disconnected (normal left inverted right x axis y axis)

Thank you Braiam and terdon.


First, let's make sure you can add the desired resolution. Based on the output of your cvt command, you need to run these two:

xrandr --newmode "1280x1024_60.00"  109.00  1280 1368 1496 1712  1024 1027 1034 1063 -hsync +vsync
xrandr --addmode VGA-0 1280x1024_60.00

That should make the new mode available in the Displays dropdown menu. If that works, see here for how to make it permanent:

Why don't my lightdm.conf edits affect my desktop screen resolution?

If that doesn't work, my guess is that the driver you are using can't support the resolution. In this case, we will have to make sure you are using the nvidia driver and to do that, you will need to install inxi, then edit your question and add the output of inxi -G. Once we have seen the output of that we'll be able to better understand what's going on.

  • Thank you for your answer. Adding the mode doesn't work. I installed inxi, edited the question.
    – user274519
    Apr 26, 2014 at 15:22
  • @Oliver OK, I was not sure if you had run both commands using VGA-0 instead of TV-0. Based on your inxi output, you are indeed using the nvidia driver. Do you have an /etc/X11/xorg.conf file? If you don't I'm afraid I'm out of ideas.
    – terdon
    Apr 26, 2014 at 15:30
  • I do have that file. It contains: Section "Device" Identifier "Default Device" Option "NoLogo" "True" EndSection
    – user274519
    Apr 26, 2014 at 15:59
  • @Oliver hmm, none of that should affect anything. Braiam might be on to something though, I guess it's possible that your 10 year old card is not supported by the latest drivers. It might well be a good idea to try the open source drivers as he suggested instead.
    – terdon
    Apr 26, 2014 at 21:27
  • Apparently got this one right ;)
    – Braiam
    Apr 27, 2014 at 14:20

You must log in to answer this question.