3

I worked for many years with ubuntu nas server. Now last week I updated my server from 13:10 to 14:04. That in itself went well except Remote Desktop. The server is in the attic and I control it from my work PC thru VNC. After the update, this no longer works and VNC gives the following message: No supported authentication methods!

I have vnc server installed as a separate application, but I also get the same error message. When I look at my settings, everything is still the same.

Does anyone know how I can "fix" it without reinstall ubuntu?

Thanks for the help.

Grt JayDee

1
  • Same problem here. I love how stuff just inexplicably breaks with every update. – endolith Aug 17 '14 at 17:40
7

Seems that vino was changed to require encryption by default, but only supports old encryption methods that are not commonly available.

This is a workaround till they fix it:

  1. Install dconf-editor: sudo apt-get install dconf-editor
  2. Start it.
  3. Navigate to: org > gnome > desktop > remote-access
  4. Disable "require-encryption"

(from this thread on discourse).

Other way to fix it is disable vino and only use x11vnc server. x11vnc will work as long as no other desktop screening or screen sharing program is active.

3
  • I can confirm this fixed my problem trying to connect via iPad using Mocha VNC. Thanks so much! EDIT: I should say that the first method (dconf-editor) is what worked. – Josh Mohan Jun 22 '14 at 18:43
  • this doesn't work for me. ~> dconf read /org/gnome/desktop/remote-access/require-encryption false ~> dconf read /desktop/gnome/remote-access/enabled false ~> gsettings get org.gnome.Vino require-encryption false Real VNC Viewer still says "The connection was refused by the host computer" – endolith Aug 17 '14 at 18:10
  • actually I had to open vino-preferences on the server and re-enable everything that somehow got turned off. – endolith Aug 17 '14 at 19:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.