10

getting my new 14.04 rig going ;-) Pretty happy with it, everything seems to be working great.

For Chinese input, however, having a problem. I went through the typical steps, open language in settings, let it install some stuff, then add Chinese and choose Ibus. Then, after logging in and out, I see the language icon in my system tray.

However, when I go to add the Chinese into Ibus, it only lets me choose "Chinese", which isn't an input method. It should give me a bunch of choices like pinyin, bopomo or whatever, I only use pinyin so don't know those names.

I saw someone online had a little command which helped people with similar problems, but it did not work for me, even after a re-start.

So, anyone got a solution?

Edit: Here is what it looks like, just "Chinese" in the list, when there should be a bunch of input options like pinyin, potomofo, and so on. No options for input method

  • Which Ubuntu distro are you on? Especially if you are on standard Ubuntu, you may want to read help.ubuntu.com/14.04/ubuntu-help/keyboard-layouts.html – Gunnar Hjalmarsson Apr 26 '14 at 9:37
  • Thank you for the advice, I am on 14.04 64 bit, standard. Its weird because ibus-pinyin is installed, but I don't get the option. – RhZ Apr 26 '14 at 10:07
  • I tried some commands with Ibus and am getting weird results. Ibus restart doesn't make the indicator disappear at all. That indicator is just a standard one, where is the Ibus settings? Then, I tried ibus engine and it said no engine started...then I tried ibus list-engine and it said can't connect to ibus...I don't think ibus is running... – RhZ Apr 26 '14 at 10:42
  • ibus address returns (null)...I feel so stupid now what am I missing. – RhZ Apr 26 '14 at 10:44
  • Sigh...I am having the same problem... – user15149 Oct 12 '14 at 0:15
10

1. I think you need to open Language Support and install Chinese(simplifed or traditional)

2. You can try to install Chinese input method manually

sudo apt-get install ibus-pinyin 
sudo apt-get install ibus-sunpinyin

3. Restart IBus daemon

ibus restart

4. Then you can find Chinese(pinyin) input method in Text Entry Setting. enter image description here

Hope this is helpful.

  • Thanks to both of you in advance. Ok both of you are talking about Text Entry Settings, and maybe I am being dense, but the picture I provide above is the Text Entry Settings. I can put Chinese in there, but it is just Chinese, no input method like pinyin or anything. I have installed Chinese in languages, then I go to Text Entry...and add Chinese...and then nothing, no entry. Only Ibus itself is asking me what type of Chinese entry I want to use. Still, I guess I am doing something wrong, Ibus isn't working right. – RhZ Apr 26 '14 at 12:07
  • So, you say I will have pinyin there in Text Entry, (and I am glad for the confirmation about that), but for some reason, I don't. See picture above pls. – RhZ Apr 26 '14 at 12:10
  • @RhZ: Ok, now I see. Indeed the installed IM engines should appear there. Even if it should be sufficient to log out and re-login after installing an engine, have you tried to reboot? – Gunnar Hjalmarsson Apr 26 '14 at 12:21
  • Ok I think its getting better. Before, I was missing the engine entirely, now I have an engine with a million different options. However, when I go to choose, its still not there. – RhZ Apr 26 '14 at 13:03
  • I tried uninstalling Chinese and restarting, then I checked, the engine had 3 options, but when I re-installed now the options are only 2 (google which I had downloaded and sun), but not the regular pinyin. So it changed when I installed Chinese. I think this may be because I am in China, it recognized my locale and gave me Chinese automatically...I wish they would just stop messing with people. If I wanted a localized system I would have asked for it... – RhZ Apr 26 '14 at 13:10
6

Got it! I am so stupid haha...

Just run ibus-setup, that will get ibus going and you can choose your input method.

So simple...and I will never get that hour back ;-)

But it does seem buggy to be honest.

  • It sounds to me as if you have missed that you are supposed to use System Settings -> Text Entry instead of ibus-setup. Did you read the document I linked to? – Gunnar Hjalmarsson Apr 26 '14 at 11:21
  • 2
    Thanks for your patience. I replied above to Gino. That pic I put in the question is Text Entry. I have Chinese there, but no specific input. – RhZ Apr 26 '14 at 12:09
1

Once the Ibus-Pinyin installed, the ibus-setup is not even necessary, just chose in the language list "Chinese Pinyin" instead of "Chinese". Once installed, you can configure it easily from language choice list or from the Pinyin icon.

I wasted a lot of time on this question, I hope you'll get it quickly.

  • yes you are right. But I think I ran into a bug. But its all good now – RhZ Apr 30 '14 at 13:07

protected by Community Aug 31 '14 at 9:55

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.