0

My Fn+Volume up/down key on a MacBook Pro late 2011 used to be functional as usual in Ubuntu 13.10. After upgrading to Ubuntu 14.04, I have to press the Fn+Alt+Volume up/down keyboard combination to do the same. The weird thing is when I set this function in System Settings -> Keyboard -> Shortcuts -> Sound and media, I only push Fn+Volume up/down. It sets the key binding correctly without Alt while not working with the Alt.

4

The problem is that an incorrect string is set in dconf key:

Original (working) value:

~$ gsettings get org.gnome.settings-daemon.plugins.media-keys volume-up
'XF86AudioRaiseVolume'

After running "unity-control-center keyboard", and setting the shortcut for volume-up key:

~$ gsettings get org.gnome.settings-daemon.plugins.media-keys volume-up
'AudioRaiseVolume'

The new value misses the "XF86" part of the string, and does not work.

You can get the key working again by resetting the value, with:

~$ gsettings reset org.gnome.settings-daemon.plugins.media-keys volume-up
~$ gsettings reset org.gnome.settings-daemon.plugins.media-keys volume-down

The bug already reported: https://bugs.launchpad.net/ubuntu/+source/unity-control-center/+bug/1302885

  • Thanks for the answer, New to Ubuntu and linux, Had looked everywhere, nobody pointed to this. – codisfy Jun 1 '14 at 14:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.