I can't believe that there was not a question or open issue for this before.

I've recently installed ubuntu 14.04 along with my favourite webapps; and I, unfortunately, realised that they're not integrated with firefox/chromium anymore. Instead, they use a minimal browser which I am not interested in.

Within the few reasons why I'm still using unity and I haven't moved to gnome or xfce, it's the unity-webapps. I haven't known any other OS or Desktop Environment (DE) which integrates the internet webapps in the computer and, at same time, keeps the power of the web-browser and the computer-using style.

I loved to be able to have tens of opened tabs & to be in one-click far away to my facebook tab. And I loved to create new tabs in the same windows that I used to have my open webapp. No mention of all the capabilities which firefox provides me...

So, is there any workaround to get back the unity-webapps integrated in firefox/chromium? I've already checked the system settings and the unity tweak tool with no luck.

The major issue of the unity-webapps was there are few of them, they need more features and more stability. If ubuntu doesn't fix this, I'll strongly think in moving to another DE. C'mon Canonical, I'm not using a tablet, I have got 6GB of RAM and I want to see many apps and many pages at the same time.

EDIT - I have reported a bug in launchpad for this issue: https://bugs.launchpad.net/libunity-webapps/+bug/1329046

EDIT - My proposal of solution: The solution might be archieved following the path I'm describing below. I can only show it, somebody has to walk through it.

  1. get the source for 14.04 unity-webapps
  2. edit the place where webapp-browser is changed to be by default for unity-webapps inside libunity-webapps.
  3. Compile again the code for 14.04 and post the output package here.

The source for libunity is hosted here: http://packages.ubuntu.com/source/trusty/libunity-webapps

  • your question would be improved if you added the names of your "favorite webapps"
    – Elder Geek
    Commented Apr 30, 2014 at 21:10
  • @ElderGeek All of them open in the lightweight Ubuntu browser and not the default browser. Commented Apr 30, 2014 at 21:15
  • @ElderGeek No not really :/ Commented Apr 30, 2014 at 22:44
  • @Akronix can you give me a specific example of a favourite webapp? I would like to research this further. Thank you
    – Elder Geek
    Commented Apr 30, 2014 at 23:03
  • @ElderGeek facebook, youtube, telegram, google docs, and gmail (if it works, cause in 13.04 it didn't) And I would use more, if they had an unity-webapp version. Seriously, this is a great idea, but it needs a good implementation and full integration with unity. Using an lame duck browser instead of a powerful browser will mess up the idea.
    – Akronix
    Commented Apr 30, 2014 at 23:29

3 Answers 3


Ok at least for chromium this can be solved (somehow):

just change the line in


that says

Exec=unity-webapps-runner ...


Exec= chromium-browser --app=http://mail.google.com (for gmail)

I think it is best to move the desktop file to ~.local/share/applications and uninstall the corresponding webapp completely, since the desktop file does imo everything the whole webapp does...

I'm sure there's something similar for firefox

  • 1
    although the workaround is better than the use of the webapp-browser, it doesn't work as they used to work and the solution requires to get into files we are not suppose to edit. And also I want them working in firefox.
    – Akronix
    Commented May 6, 2014 at 23:37
  • 1
    "Files we are not supposed to edit" this is BS. There is nothing wrong with editing .desktop files and use the features your OS gives you. Nobody with a sane mind says you are not supposed to edit this files. And BTW you should copy them somewhere in your home make them executable and then right click->properties and edit them there is not even a need to edit them directly since nautilus supports editing the basic things like the exec line (command field) Commented May 7, 2014 at 17:45
  • well, I think this workaround works exactly as it used to work. At least for chromium. How was the behaviour for firefox? Did it open a new window or did it attach to an existing session?
    – wa4557
    Commented May 8, 2014 at 13:09
  • With firefox it attached to an existing session and didn't open gmail... Works fine with Chromium
    – Mark Aroni
    Commented Oct 14, 2014 at 15:07

Your solution got me thinking. It might be very easy to edit out their mistakes. Now...

Disclaimer: I don't use webapps. I installed Youtube for the purpose of solving this issue. This may not work with all webapps, you will have to try each one and post in comments so we can work it out together if you can't on your own. I post this as an answer because comments are way to short.

Let's start from the top, the command you call to run a webapp is called unity-webapps-runner. I don't know how it operates, I don't know how to fix it. What I do know is that you can very easily replace it with a bash script that launches Firefox. I am not a pro bash scripter, but this works:

for i; do 
if [[ $URL = "1" ]]; then
firefox $i;
if [[ $i = "-d" ]]; then

What the script does is that it will wait until the -d argument appear and take the next argument as a URL for Firefox.

Save this file in your ~/ directory as unity-webapps-runner and make it executable. Rename unity-webapps-runner in /usr/bin/ to something like unity-webapps-runner-classic. I presume you know you need root permissions for these actions and I presume you have knowledge concerning these particular procedures. Paste your ~/unity-webapps-runner to /usr/bin/ and try to launch a webapp, Youtube first to see that I haven't tricked you.

That should be it. Now it will launch a tab/new window in Firefox instead of the Ubuntu Browser. You could ofc replace firefox in the bash script with chromium or google-chrome or any other browser to make them launch instead.

  • euu, but is it just a launcher to the link of the webapp or it does work as unity-webapps used to work? Because the unity-webapps are more than launchers, when you clicked on the unity launcher you got the windows those webapps are open, also you could get notifications from them and control play and pause from the sound indicator. Here there is a review of their features: howtogeek.com/119560/… and, as I said, they're below their potential power. Could you check if this works like this for your solution?
    – Akronix
    Commented May 5, 2014 at 22:56
  • Oh, yes ofc. Sorry. Long night.... As for editing the answer... I am currently at school and only have access to a Windows laptop. However I still think we're not too far of with the answer. There's another command called something with "webapps-container" or similar and as far as I'm concerned that was the browser. With a bit of luck the notifications are pushed through some other process by unity-webapps-runner. Once again I cannot edit the script myself right now and test things, will be back home in about 6-7h.
    – Xweque
    Commented May 6, 2014 at 6:40
  • Could you give me an example of an application that uses these features. Tried installing GMail since it was displayed to work in the link you provided, but I could not get it to function properly, just worked as in the browser.
    – Xweque
    Commented May 6, 2014 at 15:03
  • Some examples: youtube, when you are playing a video you can pause it from the sound indicator; facebook: when you get a notification the icon on the launcher increments a counter; all should have the property to be integrated in unity as any other native application.
    – Akronix
    Commented May 6, 2014 at 18:24
  • Alright. I've come to the conclusion that I cannot solve it. I will leave the answer in case some brighter mind decides to give it a try and could find this info useful :)
    – Xweque
    Commented May 6, 2014 at 18:30

I have been researching this to, as i didn't want Chrome/Chromium, but it seems that it's not going to work with Firefox anymore. They 'dropped it'.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .