1

The gnome metacity fallback doesn't update the background producing a Windows XP-esque effect: Screenshot

I first thought this was a problem with my gnome configuration. I deleted my config and cleaned up my .* config files. But the result was the same. I'm kind of at a loss here on how to debug this.

Installed packages: http://pastebin.com/raw.php?i=nkY7Kieg

The relevant puppet configuration to reproduce the bug is located here: http://pastebin.com/raw.php?i=w2pshfUV

The problem doesn't occur with the compiz fallback (however there individual workspaces don't work). Interestingly it doesn't show any background as well.

Since there's no background available I guess that I forgot something to start (or something can't start).

So what does Gnome use for backgrounds these days? Is it still Nautilus?

I think part of the problem is that I started with the Ubuntu installer and then added all the Installers on top of it. I think the OS is missing some dependencies. But I'm not sure on how to debug these.

I deleted the following config folders:

rm -rf .gnome .gnome2 .gconf .gconfd .metacity .cache .dbus .dmrc .mission-control .thumbnails .config .Xauthority .gvfs .gegl-0.0 .local .pulse-cookie .fontconfig

Edit: Manually executing nautilus --force-desktop seems to work around the issue.

2 Answers 2

1

I had this symptom too, and it was a configuration problem.

To verify if this is a configuration problem, try creating a new throw-away user account and log in using this. If the problem is gone, it's a configuration problem.

On that note, have you deleted all of the following (or moved them out of the way)?

.config/dconf
.config/gnome-*
.config/gtk-*
.config/nautilus-*
.gconf
.local

Edit: Other things to check:

  • Are you using gdm (the GNOME Display Manager)?
  • Are the file permissions correct on your home directory? Gnome really doesn't like not being able to write configuration files.
6
  • I deleted all my dotfiles and it didn't help. However starting nautilus --force-desktop improved the situation. So I think nautilus isn't started.
    – Pascal
    May 5, 2014 at 12:50
  • I added the list of folders I deleted in the comments. I think part of the problem is that I have a massive amount of display managers installed on the system. It could be that gnome has problems interacting with all of them.
    – Pascal
    May 5, 2014 at 13:21
  • Well, you're only using one display-manager (and that really should be gdm since you're troubleshooting a Gnome display issue), so the rest shouldn't matter. Have you tried creating a throw-away user account to see if the problem also occurs there? May 5, 2014 at 17:46
  • We're using gdm since it produced less errors than KDM. I also know that this issue might not exist with just gnome installed. However since this machine is a workstation that needs to support several display managers (gnome, kde, xmonad, xfce...). So far this worked quite well (12.04, 10.04, ...). Do you know where the gnome related logs are stored? I couldn't find anything gnome related in /var/log/gdm and /var/log/syslog
    – Pascal
    May 7, 2014 at 11:39
  • 1
    Sorry, I'm all out of ideas. May 11, 2014 at 17:21
1

I'm unsure if I have the same problem as you, but I managed to work-around it by enabling the forgotten compositing feature in Metacity. Now it works much better, with small changes in the appearance.

What I did:

  1. add export WINDOW_MANAGER=$HOME/wm to your ~/.profile
  2. put the following script in ~/wm: #!/bin/bash exec "/usr/bin/metacity" "-c" "$@"
  3. chmod +x ~/wm
  4. logout and login again
2
  • I've found even faster way to do this: while logged into Ubuntu Flashback Metacity, run dconf-editor, navigate to org.gnome.metacity, and enable compositing-manager.
    – pjf
    May 23, 2014 at 9:00
  • Another update: if you don't like the window thumbnails in Alt+Tab generated by metacity in compositing mode, you can switch to the "marco" window manager (e.g. from the MATE 1.8 desktop), which is configurable using mate-window-properties. Just follow my original answer and use /usr/bin/marco in the ~/wm script.
    – pjf
    May 23, 2014 at 11:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.