2

i upgraded my computer from 13.10 to 14.04, now my screen goes black after booting, but i can access tty1.

after a little experimenting, i tried using start x it gave me this error (from /var/log/Xorg.0.log).

i have tried :

also fglrxinfo gave me this Error: unable to open display (null)

and all of them still gave me the same result, what option left that i have ? what should i do and is there a step that i miss ?

thank you

1

First of all what is the model of you graphic card ? It can be found using this command:

    lspci | grep VGA

I faced the same kind of issue recently. I had a Ubuntu 13.10 with a Radeon HD 3850 using fglrx-legacy drivers, and I was forced to remove them in order to upgrade to Ubuntu 14.04. The 14.04 generic display driver is ok but only provides a software rendering mode. I confirm that the standard fglrx drivers won't work (black screen) with old ATI cards such as the HD2xxx-4xxx series.

Once the 14.04 installed you can try to install fglrx-legacy drivers with those commands (worked for me on 13.04+, not tested yet on 14.04) or via Synaptic:

    sudo add-apt-repository ppa:makson96/fglrx
    sudo apt-get update
    sudo apt-get upgrade
    sudo apt-get install fglrx-legacy

more info in this post : Radeon HD 2000, 3000, 4000 on 12.10 Quantal: fglrx (legacy) 12.6 unsupported, what to do?

You can test if the drivers are properly working by using the following command

    glxinfo | grep render

Video drivers are always the painful part. I am also interested. Please keep us informed if you manage to solve your problem !

  • my graphic card is RADEON HD 7640G + 7470M (laptop graphic card). so it should be fine using newest fglrx. my solution (as stated below) is completely wipe the hdd and do clean install then NOT installing any fglrx driver, not a perfect solution but works, i got my screen back. – whale_steward May 6 '14 at 3:47
  • Same problem here (Mobility HD5470). By default, opensource driver is being used, which is surprisignly OK with Steam games. What made me angry was the Blackberry simulator, which requires fglrx to run in normal mode. Anyway, thanks for this answer, I'm going to try the legacy ppa and let you know about the result. – Iľja May 6 '14 at 8:15
  • Note: the same situation with 12.04 (I tried to reinstall 14.04 with 12.04, but all of the drivers available on ATI website (even the 12.1) ended with the same result. – Iľja May 6 '14 at 9:02
1

Also if it is too late for the question owner, I write this answer. I don't know if this is the right method, probably not, and I'm not an expert, but what I know is that this works for me.

Since the release Ubuntu 13.04 I had some problem after the upgrades, and in particular after the booting (I have dual boot) the monitor didn't receive any signal. After several forum researches I localize the problem. I have an old monitor and so I need to manually add some parameters to the file Xorg.conf. In the last release Ubuntu 14.04 LTS the file Xorg.conf is missing. Here what I do step by step:

  1. Enter in a tty mode or alternatively in the recovery menu select the option root (and in this last case remount the main partition sudo mount -o remount,rw /)

  2. Open (or create if it doesn't exist) with root permission the file Xorg.conf: sudo nano /etc/X11/xorg.conf

  3. Edit the file with the right parameters, here my file:

    Section "ServerLayout" Identifier "aticonfig Layout" Screen 0 "aticonfig-Screen[0]-0" 0 0 EndSection

    Section "Module" Load "glx" EndSection

    Section "Monitor" Identifier "aticonfig-Monitor[0]-0" Option "VendorName" "ATI Proprietary Driver" Option "ModelName" "Generic Autodetecting Monitor" Option "DPMS" "true" EndSection

    Section "Device" Identifier "aticonfig-Device[0]-0" Driver "fglrx" BusID "PCI:1:0:0" EndSection

    Section "Screen" Identifier "Default Screen" DefaultDepth 24 EndSection

    Section "Screen" Identifier "aticonfig-Screen[0]-0" Device "aticonfig-Device[0]-0" Monitor "aticonfig-Monitor[0]-0" DefaultDepth 24 SubSection "Display" Viewport 0 0 Depth 24 Modes "1280x1024" EndSubSection EndSection

Finally you have to reboot. Note that I added the SubSection part in order to solve my blank screen problem and in particular the parameters that I added are specific for my screen.

Please I you are an expert, or simply you find some errors, please don't hesitate to correct me!

0

in the end i gave up, waiting for answer that might never come.

so this is what i did:

WARNING: THIS WILL DELETE ALL OF YOUR DATA AND PARTITION, BACKUP FIRST!

  1. test whether ubuntu 14.04 using live cd can working properly
  2. while in live cd, choose Erase disk and install ubuntu 14.04
  3. proceed with installation

i don't know what the cause, but with this 'clean install' solution i can use ubuntu 14.04. still, i hope someone can give a better answer or solution to this problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.