I recently upgraded from ubuntu 13.10 to ubuntu 14.04. Wifi (with ralink rt3290 card) was not working in ubuntu 13.10, but after the following the guide here, How do I get a Ralink RT3290 wireless card working?, it worked fine. But in ubuntu 14.04, no matter how much I try it does not work. Can anyone please figure out what the problem is and how to solve it.


1 Answer 1


Download the file from here and follow the following steps:

  1. Extract the rt3290sta- directory into /usr/src.
  2. Run sudo dkms install -m rt3290sta -v --force.
  3. Reboot.

And you should be good :)


  • 1
    dkms wasn't installed on this system by default (originally a trusty beta install)...
    – naught101
    Commented Apr 28, 2014 at 0:13
  • 1
    Cool! Please mark the thread resolved! Commented Apr 28, 2014 at 13:12
  • 1
    It's a shame that OP didn't mark this as solved, rahul. Your answer was spot on! Thanks for posting it.
    – Blind Fish
    Commented Jul 18, 2014 at 2:05
  • Sir, thank you for posting this answer. I can confirm it works on Ubuntu 14.04, HP Probook 4540s after following this guide. Real shame the author didn't mark the thread as solved.
    – Mythul
    Commented Sep 13, 2014 at 6:56
  • 1
    to remove these drivers sudo dkms remove rt3290sta/ --all
    – shiv garg
    Commented Apr 19, 2015 at 14:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .