3

I have a clean install of Ubuntu 14.04 on a Dell XPS L502X Laptop with a discrete, optimus-enabled Nidia card.

System was working great until I decided to install bumblebee to enable the Nvidia card (from the universe repository, not the PPA). Then, opening Firefox caused the system to freeze, eating all of the available memory (according to htop). Killing Firefox unfreezes the system.

I tested Nvidia Prime instead of Bumblebee, because I thought it might be a bug in bumblebee, but when the Nvidia card is enabled in prime, Firefox freezes the system, and with the Intel card, it doesn't.

Is this a known issue? Is this happening to other people or with other apps while the Nvidia card is enabled?

3
  • Oh I can further note this is some kind of NVidia / Firefox issue, as I am running Xubuntu 14.04 and I see the same thing. Specifically I'm seeing the "plugin container" rise up to using a large amount of memory. I'm guessing it might actually have something to do with Flash since I've usually seen it when some kind of Flash content is on-screen.
    – user276019
    Apr 29 '14 at 20:20
  • As far as i know, Linux obviously ain't supporting NVidia graphic cards. From the story of Torvalds raising the middle finger to NVidia. youtube.com/watch?v=IVpOyKCNZYw Aug 23 '15 at 2:40
  • Please provide dmesg and and other relevant logs. Oct 24 '15 at 3:32
0

You can try telling Firefox not to use hardware acceleration:

  1. Disable the Nvidia card.
  2. Start Firefox.
  3. Open Firefox's preferences, go to Advanced (or use the URL about:preferences#advanced), and choose the General tab.
  4. Uncheck Use hardware acceleration when available.
  5. Quit Firefox.
  6. Enable the Nvidia card.
  7. Start Firefox.
-1

Firefox has always used a lot of memory. You can do some of the standard things to reduce memory usage like remove addons/close tabs.

You can also go to about:memory in firefox and click on 'minimize memory usage' whenever you notice things getting out of hand.

1
  • That's not what I mean, while the Nvidia card is enabled, Firefox eats ALL the available system memory, freezing it. Whereas with the Intel card behaves normally
    – caesarivs
    Apr 25 '14 at 4:33

This site is temporarily in read only mode and not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .