4

When using Copy, I get this error:

Error: "The open file ulimit level is too low, please increase it otherwise changes will not be detected properly"

The application stops syncing when it appears, why, and how do I fix it?

2
  • You will have to be more specific.
    – psusi
    Apr 25, 2014 at 3:28
  • @psusi: Thanks for your comment. I made the question more clear. I just wish to contribute to askubuntu writing this answer. Apr 25, 2014 at 3:31

1 Answer 1

11

1) Create file /etc/sysctl.d/60-copy.conf

2) Open that file and write:

fs.inotify.max_user_watches = 20000
fs.file-max = 800000

3) Save the file and exit

4) Go to the terminal and apply those settings by typing:

sudo sysctl -p /etc/sysctl.d/60-copy.conf 

5) Launch the Copy app again and it should work.

3
  • 1
    I don't know what this app is since the link you gave is dead and gone. But if you are going to suggest adding files to /etc/sysctl.d, please read the README in that directory first. :)
    – chaskes
    Apr 26, 2014 at 3:06
  • 1
    @chaskes: Thanks for your comment. This is app is competing against Dropbox. For more information, please see the app's tag wiki. Apr 26, 2014 at 6:02
  • For some reason this only worked for me once. After that I tried increasing the limits even 100 times more than this and I couldn't get the CopyAgent to start.
    – Mike
    Oct 17, 2015 at 21:05

Not the answer you're looking for? Browse other questions tagged or ask your own question.