3

I installed Okular pdf viewer in my Ubuntu 14.04.

Okular is a KDE based software and it emits a KDE notification sound when I do some actions for example when I overwrite a file.

Is it possible that I disable these KDE notifications sounds and how do I do it?

2

I run Ubuntustudio 15.10, and have installed the KDE-app Kolourpaint. Wonderful app, but the sounds ... terrible.

  1. Open File Manager and enable "View Hidden Files"
  2. Go to FileSystem/usr/share
  3. Open a terminal there and type
  4. sudo chmod -R 777 sounds
  5. Open FileSystem/usr/share/sounds in the File Manager
  6. Delete every KDE*.ogg file.

Now no more KDE system sounds will disturb you.

  • 1
    Not really the best solution. Deleting system files isn't what we call "safe," and providing an iffy workaround for the question isn't what we call "an answer." – TheWanderer Oct 24 '15 at 22:17
  • THANK YOU! Perfect solution - at least this one works. I am running KMail under Xfce (no KDE) and these notification sounds were driving me nuts. Thank you!!! – johndodo Oct 28 '16 at 9:25
  • After trying the other solutions, which didn't work because they are out of date, this is what i did too. They are just sound files being deleted, i am not concerned about any unforeseen impact. – kim holder Apr 6 '17 at 19:52
0

If you have KDE installed you disable sounds using systemsettings https://falsecolour.com/aw/computer/okularsounds/index.html

If you don't have full KDE, then you might be out of luck, I don't know.

Edit: you can try this in the second case: https://mail.kde.org/pipermail/okular-devel/2012-January/010986.html

0

What you are hearing is not okular's sounds, but KDE notification sounds. The best way to manage those is to install systemsettings: sudo apt-get install systemsettings

I did not want to have any sounds, so I switched them completely off: run systemtettings => Application and System Notifications => Player Settings => No audio Output.

Source: https://superuser.com/a/281242/334492

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy