So I've installed 14.04 and after hours of working on it I finally got grub to work. I noticed during the live cds that my main monitor (powered by my nvidia card) wasn't working, and I figured that a proprietary driver install would fix it. It didn't. I also tried the nouveau driver, but to no avail. I understand I need to go to the nvidia-settings to enable the monitor, but I cannot get it to load anything but the options page and some other useless tab.

I remembered this issue back when I used to use my old laptop (I ran 12.04, and I would've had that on this PC sooner but I was waiting for 14.04), and I knew that running something like optirun -b primus glxgears would fix it, but it didn't. I get this message whenever I try to run something with optirun.

$ optirun -b primus glxgears
[ 1041.451645] [ERROR]The Bumblebee daemon has not been started yet or the socket path /var/run/bumblebee.socket was incorrect.
[ 1041.451662] [ERROR]Could not connect to bumblebee daemon - is it running?

I tried the steps listed here, http://ubuntuforums.org/showthread.php?t=1960883 but I can't get the very first command to work, and the other solutions did not help either.

Does anyone know of a solution? Thanks.

Edit: I have also tried purging and reinstalling it, no difference.

Edit #2: I know this is a bit off topic, but if anyone knows of a way to make it to where you don't have to be root to access other drives, it would help tremendously.

Edit #3: I've tried doing as the first response has suggested, but it hasn't helped. You can view what we have tried in the comment section of that answer. I still don't have a solution, but the best thing I have to go on now would be to install a version of bumblebee 3.0 and behind. Anyone know how to do this?


Intel i7 4770k

MSI 780 Ti Gaming

16 Gigs Ram

256 Gig Samsung 840 Pro SSD and 1TB HDD for storage

Dual booting Windows 7 (or Winderp$ as I like to call it) and Ubuntu

  • Have you tried nvidia-prime? In my experience, nvidia-prime worked better for me and bumblebee just simply failed to start. It did not even detect the nvidia card after installation. Although it does not make the cut for real time switching, it does give you nvidia graphics if you want to play games
    – Ubuntuser
    May 6 '14 at 18:52
  • I was going to use that, but it doesn't work either. If you have any tips on getting it to work, please let me know. I'll post the error message in the main post later, don't let me forget. I'm going to have to switch back over, and I'm not ready to that that now. Thank you for your post btw. May 6 '14 at 22:06
  • You are right. It has stopped working for me as well. I am not sure if this is a problem with Ubuntu 14.04. It used to work for the beta builds.
    – Ubuntuser
    May 8 '14 at 5:17
  • Any way to get a beta build and test it? Also, when I tried a manual install of the drivers, but ctrl+alt+f1 doesn't do anything but make my mouse disappear... is that still how you get into that terminal thingy? It's been a while since I've used Linux (4-8 months or so), so I'm not too familiar with all the changes... Anyway the error message was something like 2 lines of a message in the terminal, like prime has stopped working or prime is not working. Anyways it started with prime did something... May 8 '14 at 17:13

Not entirely sure how I fixed it the first time on this system, however I have learned a lot on this issue, and if anyone is having similar issues or symptoms, please feel free to PM me or do something to contact me, and I'll be glad to help (a bit).

I'll tell how I got my Nvidia drivers to work on my latest try. Note that I haven't quite gotten my second monitor running off of integrated graphics to work yet, but because the Nvidia drivers are working, I'm thinking it shouldn't be too big of a hassle.

I've found that manual installs work best for installing nvidia drivers, so go to the geforce site and download the latest drivers. By default, it'll most likely go into /Downloads, but if not, just know where it is. Then, you'll want to press

ctrl + alt +F1-F6 (each is a different login)

And then sign in to your account. Then, you'll want to use

sudo stop lightdm 


sudo service lightdm stop

This shuts down the things that are using the GUI, so they can be updated.

Then run

chmod +x ~/* Folder that said driver is located in * / * Driver *

For example,

chmod +x ~/Downloads/NVIDIA-Linux-x86_64-343.13.run

Make SURE that you have the entire name of the driver, otherwise this will not work! Caps do matter!

What you just did was make the file executable. Next, you'll want to run the following command, changed of course like the example above to fit your directories/driver versions.

sudo sh ~/Downloads/NVIDIA-Linux-x86_64-343.13.run

For me, tabbing the rest of the NVIDIA-Linux-x86_64-343.13.run file does not work, but it is CRUCIAL THAT YOU DO THIS. If nothing happens after you run the second command, check your caps and spelling to make sure they are right. You have to go through the program using the keyboard to correctly install it. For me it will tell me that something went wrong right off the bat, just keep going and see if it still works. If it asks you to install 32 bit libraries, do so. Some programs (like steam games) will not run unless you have these installed.

After all of the above has been done, one final command must be completed, or of course you could reboot.

sudo start lightdm (or sudo service lightdm start)

Then, you'll do

ctrl + alt+ F7-F9ish (F7 is usually default, some people have different F keys though)

This should have worked for most people, if not keep looking, there's always a fix. If anyone knows something about getting virtual 7.1 audio to work, please message me somehow. Thanks. Hope I helped someone.

Edit:I've also heard x-swat repositories work better at times. Not sure about that, but worth a try.

(Pro tip, whenever Nvidia related stuff goes wrong, watch this YouTube video.)


I also had issues with my nVidia drivers after installing Ubuntu 14.04.

First of all, open a terminal and purge everything you've already done with nVidia.

$ sudo apt-get remove --purge nvidia-*

Then take a look at Luis' very comprehensive answer on this topic:

How do I install the Nvidia drivers?

I read through and followed his guide, and I was able to get my card/drivers working.

As my version was 14.04 (beta), I chose the Xorg Edgers PPA (instead of the X-Swat PPA) as follows:

$ sudo add-apt-repository ppa:xorg-edgers/ppa
$ sudo apt-get update
$ sudo apt-get upgrade
$ sudo apt-get install nvidia-334

I installed the 334 driver because I have a GTX 750Ti (which was known to have issues with some Linux distros). The 334 driver was released last month and addressed those issues.

For assistance in figuring-out the "recommended" driver for you, run this command:

$ ubuntu-drivers devices | grep recommended

That should produce output similar to this:

driver   : nvidia-337 - third-party free recommended

In any case, read through the answer that I linked above, and it should lead you in the proper direction. Step #5 contains information about Bumblebee.

  • So will this be using the proprietary drivers or the noveau drivers? And you mentioned the 750 having issues on some linux distros, so I figured I should post my specs to see if there are any issues that you may know, I have now added them to my original post. Please let me know if there are any issues with it. Do the Edgers drivers give better performance at a cost of slight stability? He was not too clear on that post. I didn't know there were different ppas for drivers on Linux. Thanks for the post, I will test this out again and see if this fixed it. Continued in next comment. Apr 25 '14 at 0:38
  • How does this fix bumblebee? I thought the issue was with bumblebee, not with the drivers. I would rather use Nvidia's new bumblebee type thing, I think they called it Prime or something with a P. The only thing I can guess is wrong is that I may be missing the file (as the error reports). If this does not help, I will ask for someone to send me that missing file. Thanks again. Apr 25 '14 at 0:40
  • Yes, this solution does involve installing the proprietary drivers. Edgers is more stable and has been shown to perform better with newer cards.
    – Aaron
    Apr 25 '14 at 0:43
  • Check the link out, it has info for Bumblebee further down.
    – Aaron
    Apr 25 '14 at 0:44
  • All right, I have done as instructed but the same issue is here. I think I am missing the actual file, because when I went in nautilus to find it, it was not there. Just tried running the normal nvidia-settings and got this: nvidia-settings ** (nvidia-settings:5629): WARNING **: PRIME: Failed to execute child process "/usr/bin/prime-supported" (No such file or directory) ** Message: PRIME: is it supported? no Segmentation fault (core dumped) Sorry about the bad format, I don't know how to get it fancy like you guys always do. I also know that nvidia-prime is installed. Apr 25 '14 at 0:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.