I can't believe this bug has still not been solved with Ubuntu 14.04 ? On my 2 laptops, Acer and Asus, on a random basis, the keyboard layout switch from FR to EN.

This is very frustrating when you type a password and can't see the letters.

How to solve that for good ?

  • Are you using auto-login? – Elder Geek May 21 '14 at 23:19
  • No autologin.strange, bug hasn't appeared for 1 week, perhaps due to last updates ? – dupont May 23 '14 at 18:20
  • spoke to fast, bug is back today !!! – dupont May 24 '14 at 7:05

This should fix the problem in 13.10 and 14.04:

In the ubuntu software center, install "dconf Editor" (dconf-editor) (if you don't already have it). Open it, then open desktop -> ibus -> general. Now enable the property "use-system-keyboard-layout". (You want it to have a checkmark next to it.)

Source: https://bugs.launchpad.net/ubuntu/+source/indicator-keyboard/+bug/1240198

  • It was there, but still didn't work... – 0xbaadf00d Aug 8 '16 at 10:11

Run command:

sudo dpkg-reconfigure xkb-data  

Now use the Keyboard Icon to reset to whatever it should be - viz the diagram.

enter image description here

  • 2
    unfortunatelly, bug is still here at random ! – dupont May 1 '14 at 17:51

I found at http://ubuntuforums.org/showthread.php?t=1376466 the solution. It appears that there is a issue in defining the keyboard layout when the UID of the user is 1000.

You must logout of your current session and login as root (if you didn't previously, before logout set a root password by running in terminal sudo passwd root and follow the steps).

At login screen hit on the keyboard CTRL + ALT + F1.

Do login as root. Type usermod -u 1001 your_user_name. 1001 is just a suggestion, you can put another. Then reboot by typing reboot.

Hope it works!

  • Impossible to login as root, password rejected !!!even if i've just changed the password. I tried 2 times. – dupont Jun 1 '14 at 11:47
  • login incorrect what should I enter as login ? – dupont Jun 1 '14 at 11:58
  • Try to login as usual, then open Terminal and try get root running sudo su. – Peterson Domingos Jun 3 '14 at 16:31
  • terminal return user ... is currently used by process 1611 – dupont Jun 3 '14 at 18:28
  • Is that when you try to run usermod? Can you get su running sudo su in Terminal? If so, try to set the root password typing passwd. Then try that step at login screen again. Sorry if im being redundant, I don't know exactly the steps you took. – Peterson Domingos Jun 4 '14 at 17:56

Just run the following command line in a terminal and configure your keyboard layout correctly:

sudo ibus-setup

then reboot and enjoy. :)

  • doesn't work, still EN at reboot at random even if EN is not in the layout menu !!! – dupont May 31 '14 at 7:29

Just type:

setxkbmap fr

on a terminal.

I tried it on Raspberry Pi, Debian, Ubuntu and Fedora.

  • doesn't work stil EN at reboot! – dupont May 31 '14 at 7:28
  • Thanks, at least I can write characters like "-" now... damn Ubuntu Unity GUI, can't even set Keyboard-Layout in Keyboard Menu. – kungfooman Jan 24 '16 at 7:47

Trashing the file in /home/user/.config/ibus solved the issue.

  • Can you explain better? "Trashing the file", what file? – Seth Aug 24 '14 at 2:16
  • Trash the entire ibus folder and relogin. – jelies Sep 20 '14 at 21:48
  • does not work for me! – kdureidy May 11 '16 at 23:20

Not the answer you're looking for? Browse other questions tagged or ask your own question.