2

I tried to install the most recent nvidia-331 driver (ubuntu-x-swat repository).

However, it seems like the installer tries to apply a wrong patch (3.10 patch, but I have a 3.11 kernel) -> the installation fails.

me@pc ~ $ sudo apt-get install nvidia-331
[...]
Loading new nvidia-331-331.62 DKMS files...
Building only for 3.11.0-12-generic
Building for architecture x86_64
Building initial module for 3.11.0-12-generic
Error! Application of patch buildfix_kernel_3.10.patch failed.
Check /var/lib/dkms/nvidia-331/331.62/build/ for more information.

How can I force dkms to apply the correct patch?

  • Found a solution for my situation (while this is not a solution for the problem itself): Installed a newer kernel, namely 3.13. Afterwards, the friver compiled fine. – MrD Apr 26 '14 at 13:49
1

I understand you solved your problem by upgrading, but here's how I did it:

According to dkms.conf, the 3.10 patch should be applied for both 3.10 and 3.11 kernels, but I guess somewhere along the way the patch became unnecessary.

The solution is to edit /usr/src/nvidia-331-xxx.yy/dkms.conf. Change the line saying

PATCH_MATCH[0]="^3.1[01]"

to

PATCH_MATCH[0]="^3.10"

and then reconfigure the package:

sudo dpkg-reconfigure nvidia-331

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.