I have an Asus N76VB notebook with Ubuntu 14.04 and TLP for power managment. However, the fan is always on. It's not really loud, but it's annoying. My CPU usage is around 1-2%. It's clocked at 1.20 GHz.

I've added acpi=force to my boot parameters but it doesn't change anything.

/proc/acpi/fan: No such file or directory
/proc/acpi/thermal_zone: No such file or directory

I've loaded all Asus ACPI modules.

lsmod | grep asus:

asus_nb_wmi            16990  0 
asus_wmi               24191  1 asus_nb_wmi
sparse_keymap          13948  1 asus_wmi
video                  19476  2 i915,asus_wmi
wmi                    19177  2 mxm_wmi,asus_wmi

Somehow, it can read the temperatures.


Adapter: Virtual device
temp1:        +43.0°C  (crit = +108.0°C)

Adapter: ISA adapter
Physical id 0:  +44.0°C  (high = +87.0°C, crit = +105.0°C)
Core 0:         +44.0°C  (high = +87.0°C, crit = +105.0°C)
Core 1:         +42.0°C  (high = +87.0°C, crit = +105.0°C)
Core 2:         +39.0°C  (high = +87.0°C, crit = +105.0°C)
Core 3:         +39.0°C  (high = +87.0°C, crit = +105.0°C)

Adapter: ISA adapter
temp1:        +43.0°C  

I really hope someone knows how to solve this. Almost all information I could find was about saving power to create less heat.

I got Intel and NVIDIA (GeForce 740M) graphics but I'm almost anytime on Intel.

$ sudo lshw -c display
       description: VGA compatible controller
       product: 3rd Gen Core processor Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:43 memory:f7400000-f77fffff memory:d0000000-dfffffff ioport:f000(size=64)

fwts fan:


  • I've updated my question. – Louis Matthijssen May 4 '14 at 11:10
  • 1
    have you looked to updating your BIOS with whatever the latest is recommended from your laptop manufacture? This sometimes resolves ACPI issues. – fossfreedom May 4 '14 at 12:32
  • Yeah, there was an update that "updated the thermal policy" but I already installed it before I installed Ubuntu. – Louis Matthijssen May 4 '14 at 12:37
  • Why not contact the manufacturer and ask why the "updated thermal policy" isn't working properly? You may wish to visit support.asus.com/contactus.aspx?SLanguage=en Options 5,6, or 7 might be a good place to start. Good luck! – Elder Geek May 7 '14 at 20:54
  • Thank you, I'll give it a try, but I don't think it'll help as Linux is probably "not supported". Also, I have contacted them earlier and they seem to be unable to answer the most simple questions. – Louis Matthijssen May 7 '14 at 20:56

Canonical developed something called FWTS which will systematically test the ACPI features provided and report on their health and possible corrective solutions. Run it and post the contents here (pastbin please) and to a launchpad bug against the linux-kernel.

At a minimum run the "thermal_trip fan" tests.

[continued using results from FWTS]

Test 2 of 2: Load system, check CPU fan status.
Test how many fans there are in the system. Check for the current status of the
Loading CPUs for 20 seconds to try and get fan speeds to change.
Fan cooling_device0 current state did not change from value 0 while CPUs were
Fan cooling_device1 current state did not change from value 0 while CPUs were
Fan cooling_device2 current state did not change from value 0 while CPUs were
Fan cooling_device3 current state did not change from value 0 while CPUs were
Fan cooling_device4 current state did not change from value 0 while CPUs were
Fan cooling_device5 current state did not change from value 0 while CPUs were
Fan cooling_device6 current state did not change from value 0 while CPUs were
Fan cooling_device7 current state did not change from value 0 while CPUs were

ADVICE: Did not detect any change in the CPU related thermal cooling device
states. It could be that the devices are returning static information back to
the driver and/or the fan speed is automatically being controlled by firmware
using System Management Mode in which case the kernel interfaces being examined
may not work anyway.

OK. That confirms the issue, there's no feedback.

It doesn't appear that you have the asus-laptop module installed. Sometimes these laptop specific support modules do the trick for these components

$ sudo modprobe asus-laptop

This appears to have worked at one time, Ubuntu 12.04 on asus n76vb fan speed not working, which would make your case a regression. Unfortunately in that case the remedy was "I updated a bunch of stuff and it worked" :(.

| improve this answer | |
  • I could only run the fan test because the thermal_trip test doesn't seem to exist anymore. Results are in the question. – Louis Matthijssen May 4 '14 at 15:42
  • 1
    You're right, the module is not loaded. But I get this error: modprobe: ERROR: could not insert 'asus_laptop': No such device. I've searched a bit and added acpi_osi=Linux to my GRUB config, but it still won't work. If you have any ideas on how to fix it I would appreciate it. I'll continue searching. – Louis Matthijssen May 4 '14 at 22:27
  • I will give you the 50 rep for your effort. Thank you very much. I think this notebook has no ACPI support for fans at all, they seem to be completely controlled by the BIOS. – Louis Matthijssen May 8 '14 at 12:41
  • Thanks! ping me at ppetraki on freenode if you want to keep hacking. – ppetraki May 8 '14 at 17:49

Two things that I did and decreased the fan noise:

  1. Add a boot parameter, as described below
  2. Install tlp, which is a great power management utility for Linux

I did in this order, and 2 was the most effective.

To add boot parameters:

  1. sudo nano /etc/default/grub
  2. edit the line starting GRUB_CMDLINE_LINUX_DEFAULT and add acpi_osi= to the other words between the "double quotes"
  3. save
  4. run sudo update-grub
  5. reboot

More details here or here and in german here.

To install tlp:

sudo apt-get install tlp

I have to mention that in the original answer it was acpi_osi=Linux, so you might wanna try that also.

Finally, I did this in an Asus G53JW with Debian 8 (though tlp is also available for Ubuntu). It also worked on a latest 4K Asus laptop (UX501VW)

| improve this answer | |
  • Linux 3.13 has a bug related to fan control: kernel.org bug #71711 Strange / dangerous fan policy since 3.13. It looks as though the patch that introduced this bug will be reverted in Linux 3.15. In the meantime, you could try installing one of the 3.12.x mainline kernels from the kernel PPA. The bug reports seem to suggest that 3.12.17 should work okay.

  • Nouveau may have fan control issues, switching to the proprietary drivers may help if you have Nvidia graphics and the misbehaving fan is attached to the graphics card.

  • Check if there are any BIOS updates for your system. Many fan controllers rely on the BIOS correctly settings certain sensor values.

| improve this answer | |
  • Okay, as I have NVIDIA drivers and the latest BIOS update already I want to try the kernel thing. I wonder if I have to install linux-headers? If so, should I install linux-headers for both amd64 and all or only amd64? – Louis Matthijssen May 15 '14 at 17:47
  • You should not need linux-headers unless you use some external kernel module that requires recompiling (DKMS). – bain May 15 '14 at 17:52
  • I think NVIDIA uses this? So should I install both amd64 and all or only amd64? – Louis Matthijssen May 15 '14 at 17:54
  • Yes Nvidia module will use it. Install both. – bain May 15 '14 at 23:33
  • I have to report that my Asus N55SL runs about 10°C hotter since I have upgraded the system from Ubuntu 12.04 to 14.04. Could my problem be related to what is being discussed here? any way to debug this further? – Andrea Borga Aug 24 '15 at 21:05

I had the same problem with my Dell Inspiron 15 7537.

The problem went away when I changed the nVidia driver in Additional Drivers to the Nouveau driver. I don’t know why, but it worked in my case.

I'm new to Ubuntu so I was very reluctant to fiddle with the system fans. I installed a program called psensor to monitor the system temperature.

The CPU usage in System Monitor looked fine so I thought It could have been a problem with the GPU usage, which is not reported in System Monitor, and my lucky first guess was to try to change the graphics driver.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.