7

Edit (May 2019)

This is nearly 5 years old question and as one of the commenter mentioned, I have moved on. I don't want to delete it - cause there is a warning against that. So I'm putting this edit.


I know 14.04 has Kernel 3.13 and is supposed to be better at dynamic power management. My problem is the estimated remaining time keeps changing. But on an average I see 5 hours.

On same machine on Linux mint 15 (based off 13.04) I used vgaswitcharoo method and used to get at least 6 hours.

echo OFF > /sys/kernel/debug/vgaswitcheroo/switch

Does not work any more.

I've tried acpi_call method mentioned here : http://www.noobslab.com/2013/10/enable-laptop-mode-and-other-tweaks-to.html Unfortunately my card isn't listed/supported

Also (unsuccessfully) tried : http://www.webupd8.org/2014/04/prevent-your-laptop-from-overheating.html

In case there are card specific suggestions, I have following cards:

$ lspci -nn | grep VGA                               
00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09)
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Thames [Radeon HD 7500M/7600M Series] [1002:6840] (rev ff)

closed as off-topic by WinEunuuchs2Unix, Kulfy, user535733, Eric Carvalho, Zanna May 15 at 9:08

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced, that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – WinEunuuchs2Unix, Kulfy, user535733, Eric Carvalho, Zanna
If this question can be reworded to fit the rules in the help center, please edit the question.

  • This seems to be a bug. Have you checked the output of # cat /sys/kernel/debug/vgaswitcheroo/switch? – rawcoder Apr 29 '14 at 12:33
  • I see you signed on in March 2019. Next time you sign on can you delete this 5 year old question? I'm sure you've moved on by now and it is distracting having it reappear when the robot bumps it to the home page. Thanks. – WinEunuuchs2Unix May 14 at 0:06
  • @WinEunuuchs2Unix Did you mean this message for "community" ? I can see a banner below the question as "bumped to the homepage by Community". – Mandar Vaze May 15 at 6:19
  • @MandarVaze No I had look at your proile, seen you were a member for 7 years and had last signed on March 30, 2019 I believe it was. The community bumps questions without upvoted answers to the main board all the time. In this case sending the question to thousands of people who cannot answer it. – WinEunuuchs2Unix May 15 at 10:33
  • @WinEunuuchs2Unix When I tried to Delete - I saw warning against it. I'll edit it and put a disclaimer at the top. – Mandar Vaze May 16 at 11:19
0

I used powertop. I have Ubuntu 14.04 installed on a Dell Inspiron 15R 5523 laptop with AMD/Intel Hybrid graphics. I AM NOT SURE if this will work for you, but I don't think it will break the system(because powertop is pretty reliable) so nothing wrong in trying. In powertop(check out its website for downloads and usage procedures), after changing all the 'bad' parameters to 'good' in the "Tunables" tab, suddenly my fan speed decreased and so did the laptop temperature.

I have not installed any drivers(and the Catalyst Control Center) for the discrete ATI Raedon card, just the Intel Open Source drivers form the Intel website.

Since settings are not preserved on reboot, after bit experimentation, I found that changing 'bad' parameters to 'good' of the "Runtime PM for PCI Device Advanced Micro Devices, Inc. [AMD/ATI] Mars [Radeon HD 8730M]" and of each of "Enable SATA link power Management for host0" Enable SATA link power Management for host1" Enable SATA link power Management for host2" Enable SATA link power Management for host3" Enable SATA link power Management for host4" and "Enable SATA link power Management for host5". I tried to copy their echo commands onto the /etc/rc.local file to auto-execute them each time the system booted up, but it did not work (automatically 'bad' for the "...host0/1/2/3/4/5" in the Tunables tab of powertop).

I even went to the extent of checking if it really was reverted to the 'auto'(default) value in the source file...and I found, yes, it was. So, basically, this might work for a few people. Give it a try. If anyone figures out(with testing) how to keep it permanent(i.e. persistent after reboot). Currently I am not rebooting my laptop, just closing my lid to prevent doing this every damn time I reboot.

Give it a try and do comment/like if it works for you. Just want to know if this is a viable solution for a general installation in any laptop with Intel/AMD Hybrid graphics.

Not the answer you're looking for? Browse other questions tagged or ask your own question.