13

Since upgrading (fresh install) to Trusty (Kubuntu - EDIT and now Ubuntu vanilla, I switched back to further troubleshoot this) I have noticed network issues.

Exactly every two minutes my network craps out for a moment but then shortly comes back online. This is clearly reflected in the syslog:

Apr 24 07:52:45 jordan-TECRA-R840 wpa_supplicant[1271]: wlan0: CTRL-EVENT-SCAN-STARTED 
Apr 24 07:52:51 jordan-TECRA-R840 wpa_supplicant[1271]: nl80211: send_and_recv->nl_recvmsgs failed: -33
Apr 24 07:54:45 jordan-TECRA-R840 wpa_supplicant[1271]: wlan0: CTRL-EVENT-SCAN-STARTED 
Apr 24 07:54:50 jordan-TECRA-R840 wpa_supplicant[1271]: nl80211: send_and_recv->nl_recvmsgs failed: -33
Apr 24 07:56:45 jordan-TECRA-R840 wpa_supplicant[1271]: wlan0: CTRL-EVENT-SCAN-STARTED 
Apr 24 07:56:50 jordan-TECRA-R840 wpa_supplicant[1271]: nl80211: send_and_recv->nl_recvmsgs failed: -33
Apr 24 07:58:45 jordan-TECRA-R840 wpa_supplicant[1271]: wlan0: CTRL-EVENT-SCAN-STARTED 
Apr 24 07:58:50 jordan-TECRA-R840 wpa_supplicant[1271]: nl80211: send_and_recv->nl_recvmsgs failed: -33
Apr 24 08:00:45 jordan-TECRA-R840 wpa_supplicant[1271]: wlan0: CTRL-EVENT-SCAN-STARTED 
Apr 24 08:00:50 jordan-TECRA-R840 wpa_supplicant[1271]: nl80211: send_and_recv->nl_recvmsgs failed: -33
Apr 24 08:02:45 jordan-TECRA-R840 wpa_supplicant[1271]: wlan0: CTRL-EVENT-SCAN-STARTED 
Apr 24 08:04:45 jordan-TECRA-R840 wpa_supplicant[1271]: wlan0: CTRL-EVENT-SCAN-STARTED 
Apr 24 08:04:51 jordan-TECRA-R840 wpa_supplicant[1271]: nl80211: send_and_recv->nl_recvmsgs failed: -33
Apr 24 08:06:45 jordan-TECRA-R840 wpa_supplicant[1271]: wlan0: CTRL-EVENT-SCAN-STARTED 
Apr 24 08:06:50 jordan-TECRA-R840 wpa_supplicant[1271]: nl80211: send_and_recv->nl_recvmsgs failed: -33
Apr 24 08:08:45 jordan-TECRA-R840 wpa_supplicant[1271]: wlan0: CTRL-EVENT-SCAN-STARTED 
Apr 24 08:08:50 jordan-TECRA-R840 wpa_supplicant[1271]: nl80211: send_and_recv->nl_recvmsgs failed: -33
Apr 24 08:10:45 jordan-TECRA-R840 wpa_supplicant[1271]: wlan0: CTRL-EVENT-SCAN-STARTED 
Apr 24 08:10:50 jordan-TECRA-R840 wpa_supplicant[1271]: nl80211: send_and_recv->nl_recvmsgs failed: -33
Apr 24 08:12:45 jordan-TECRA-R840 wpa_supplicant[1271]: wlan0: CTRL-EVENT-SCAN-STARTED 
Apr 24 08:12:50 jordan-TECRA-R840 wpa_supplicant[1271]: nl80211: send_and_recv->nl_recvmsgs failed: -33
Apr 24 08:14:45 jordan-TECRA-R840 wpa_supplicant[1271]: wlan0: CTRL-EVENT-SCAN-STARTED 
Apr 24 08:14:50 jordan-TECRA-R840 wpa_supplicant[1271]: nl80211: send_and_recv->nl_recvmsgs failed: -33
Apr 24 08:16:45 jordan-TECRA-R840 wpa_supplicant[1271]: wlan0: CTRL-EVENT-SCAN-STARTED 
Apr 24 08:16:50 jordan-TECRA-R840 wpa_supplicant[1271]: nl80211: send_and_recv->nl_recvmsgs failed: -33
Apr 24 08:18:45 jordan-TECRA-R840 wpa_supplicant[1271]: wlan0: CTRL-EVENT-SCAN-STARTED 
Apr 24 08:18:50 jordan-TECRA-R840 wpa_supplicant[1271]: nl80211: send_and_recv->nl_recvmsgs failed: -33
Apr 24 08:20:45 jordan-TECRA-R840 wpa_supplicant[1271]: wlan0: CTRL-EVENT-SCAN-STARTED 
Apr 24 08:20:50 jordan-TECRA-R840 wpa_supplicant[1271]: nl80211: send_and_recv->nl_recvmsgs failed: -33

I haven't spent too much time troubleshooting yet, I have only just installed a day ago. I was wondering if anyone has seen this issue before? I don't recall seeing this back when I was on Ubuntu 13.10 with the exact same hardware only 3 days ago.

Hardware: Tecra R840-S8430 Network controller: Intel Corporation Centrino Advanced-N 6230 [Rainbow Peak] (rev 34) Flavor: Kubuntu + Ubuntu Release: 14.04 LTS


Update - More information (5/05/05)

Yes, this appears to be dropping my connection. Here is some syslog from a typical drop, I have to disable/re enable wifi to get it back up:

May  5 09:29:57 Oban kernel: [74616.819616] wlan0: deauthenticated from 00:26:62:4f:c3:f6 (Reason: 6)
May  5 09:29:57 Oban wpa_supplicant[1368]: wlan0: CTRL-EVENT-DISCONNECTED bssid=00:26:62:4f:c3:f6 reason=6
May  5 09:29:57 Oban NetworkManager[1151]: <warn> Connection disconnected (reason 6)
May  5 09:29:57 Oban kernel: [74616.851674] cfg80211: Calling CRDA to update world regulatory domain
May  5 09:29:57 Oban wpa_supplicant[1368]: wlan0: SME: Trying to authenticate with 00:26:62:4f:c3:f6 (SSID='Air' freq=2462 MHz)
May  5 09:29:57 Oban NetworkManager[1151]: <info> (wlan0): supplicant interface state: completed -> disconnected
May  5 09:29:57 Oban wpa_supplicant[1368]: wlan0: CTRL-EVENT-SCAN-STARTED 
May  5 09:29:57 Oban NetworkManager[1151]: <info> (wlan0): supplicant interface state: disconnected -> authenticating
May  5 09:29:57 Oban kernel: [74616.921570] wlan0: authenticate with 00:26:62:4f:c3:f6
May  5 09:29:57 Oban kernel: [74616.925036] wlan0: send auth to 00:26:62:4f:c3:f6 (try 1/3)
May  5 09:29:57 Oban kernel: [74616.931650] cfg80211: World regulatory domain updated:
May  5 09:29:57 Oban kernel: [74616.931654] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
May  5 09:29:57 Oban kernel: [74616.931656] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
May  5 09:29:57 Oban kernel: [74616.931658] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
May  5 09:29:57 Oban kernel: [74616.931659] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
May  5 09:29:57 Oban kernel: [74616.931661] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
May  5 09:29:57 Oban kernel: [74616.931662] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
May  5 09:29:57 Oban kernel: [74617.031487] wlan0: send auth to 00:26:62:4f:c3:f6 (try 2/3)
May  5 09:29:57 Oban kernel: [74617.035474] wlan0: authenticated
May  5 09:29:57 Oban wpa_supplicant[1368]: wlan0: Trying to associate with 00:26:62:4f:c3:f6 (SSID='Air' freq=2462 MHz)
May  5 09:29:57 Oban NetworkManager[1151]: <info> (wlan0): supplicant interface state: authenticating -> associating
May  5 09:29:57 Oban kernel: [74617.039506] wlan0: associate with 00:26:62:4f:c3:f6 (try 1/3)
May  5 09:29:57 Oban kernel: [74617.043029] wlan0: RX AssocResp from 00:26:62:4f:c3:f6 (capab=0x431 status=0 aid=4)
May  5 09:29:57 Oban wpa_supplicant[1368]: wlan0: Associated with 00:26:62:4f:c3:f6
May  5 09:29:57 Oban kernel: [74617.050233] wlan0: associated
May  5 09:29:57 Oban kernel: [74617.050393] cfg80211: Calling CRDA for country: US
May  5 09:29:57 Oban NetworkManager[1151]: <info> (wlan0): supplicant interface state: associating -> associated
May  5 09:29:57 Oban kernel: [74617.056664] cfg80211: Regulatory domain changed to country: US
May  5 09:29:57 Oban kernel: [74617.056673] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
May  5 09:29:57 Oban kernel: [74617.056679] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2700 mBm)
May  5 09:29:57 Oban kernel: [74617.056685] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 1700 mBm)
May  5 09:29:57 Oban kernel: [74617.056690] cfg80211:   (5250000 KHz - 5330000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
May  5 09:29:57 Oban kernel: [74617.056695] cfg80211:   (5490000 KHz - 5600000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
May  5 09:29:57 Oban kernel: [74617.056700] cfg80211:   (5650000 KHz - 5710000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
May  5 09:29:57 Oban kernel: [74617.056705] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 3000 mBm)
May  5 09:29:57 Oban kernel: [74617.056711] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 4000 mBm)
May  5 09:29:57 Oban NetworkManager[1151]: <info> (wlan0): supplicant interface state: associated -> 4-way handshake
May  5 09:29:57 Oban wpa_supplicant[1368]: wlan0: WPA: Key negotiation completed with 00:26:62:4f:c3:f6 [PTK=CCMP GTK=CCMP]
May  5 09:29:57 Oban wpa_supplicant[1368]: wlan0: CTRL-EVENT-CONNECTED - Connection to 00:26:62:4f:c3:f6 completed [id=0 id_str=]
May  5 09:29:57 Oban NetworkManager[1151]: <info> (wlan0): supplicant interface state: 4-way handshake -> completed
May  5 09:31:34 Oban kernel: [74713.775114] wlan0: deauthenticated from 00:26:62:4f:c3:f6 (Reason: 6)
May  5 09:31:34 Oban wpa_supplicant[1368]: wlan0: CTRL-EVENT-DISCONNECTED bssid=00:26:62:4f:c3:f6 reason=6
May  5 09:31:34 Oban NetworkManager[1151]: <warn> Connection disconnected (reason 6)
May  5 09:31:34 Oban kernel: [74713.812782] cfg80211: Calling CRDA to update world regulatory domain
May  5 09:31:34 Oban NetworkManager[1151]: <info> (wlan0): supplicant interface state: completed -> disconnected
May  5 09:31:34 Oban kernel: [74713.816717] cfg80211: World regulatory domain updated:
May  5 09:31:34 Oban kernel: [74713.816724] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
May  5 09:31:34 Oban kernel: [74713.816729] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
May  5 09:31:34 Oban kernel: [74713.816732] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
May  5 09:31:34 Oban kernel: [74713.816735] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
May  5 09:31:34 Oban kernel: [74713.816738] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
May  5 09:31:34 Oban kernel: [74713.816741] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
May  5 09:31:34 Oban NetworkManager[1151]: <info> (wlan0): supplicant interface state: disconnected -> scanning
May  5 09:31:49 Oban NetworkManager[1151]: <warn> (wlan0): link timed out.
May  5 09:31:49 Oban NetworkManager[1151]: <info> (wlan0): device state change: activated -> failed (reason 'SSID not found') [100 120 53]
May  5 09:31:49 Oban NetworkManager[1151]: <info> NetworkManager state is now DISCONNECTED
May  5 09:31:49 Oban NetworkManager[1151]: <warn> Activation (wlan0) failed for connection 'Air'
May  5 09:31:49 Oban dbus[943]: [system] Activating service name='org.freedesktop.nm_dispatcher' (using servicehelper)
May  5 09:31:49 Oban NetworkManager[1151]: <info> (wlan0): device state change: failed -> disconnected (reason 'none') [120 30 0]
May  5 09:31:49 Oban NetworkManager[1151]: <info> (wlan0): deactivating device (reason 'none') [0]
May  5 09:11:56 Oban whoopsie[1374]: online
May  5 09:31:49 Oban whoopsie[1374]: offline
May  5 09:31:49 Oban kernel: [74729.721867] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
May  5 09:31:49 Oban NetworkManager[1151]: <info> (wlan0): canceled DHCP transaction, DHCP client pid 11587
May  5 09:31:49 Oban avahi-daemon[1099]: Withdrawing address record for fe80::8a53:2eff:fe07:49c8 on wlan0.
May  5 09:31:49 Oban avahi-daemon[1099]: Leaving mDNS multicast group on interface wlan0.IPv6 with address fe80::8a53:2eff:fe07:49c8.
May  5 09:31:49 Oban avahi-daemon[1099]: Interface wlan0.IPv6 no longer relevant for mDNS.
May  5 09:31:49 Oban NetworkManager[1151]: <warn> DNS: plugin dnsmasq update failed
May  5 09:31:49 Oban NetworkManager[1151]: <info> Removing DNS information from /sbin/resolvconf
May  5 09:31:49 Oban avahi-daemon[1099]: Withdrawing address record for 192.168.1.5 on wlan0.
May  5 09:31:49 Oban avahi-daemon[1099]: Leaving mDNS multicast group on interface wlan0.IPv4 with address 192.168.1.5.
May  5 09:31:49 Oban avahi-daemon[1099]: Interface wlan0.IPv4 no longer relevant for mDNS.
May  5 09:31:49 Oban dnsmasq[1888]: setting upstream servers from DBus
May  5 09:31:50 Oban NetworkManager[1151]: <warn> Couldn't disconnect supplicant interface: This interface is not connected.
May  5 09:31:50 Oban dbus[943]: [system] Successfully activated service 'org.freedesktop.nm_dispatcher'

This is so frustrating. I can't always be on cat5. As I said before, this never happend on 13.10. I really do not want to downgrade. Is there a way I can use the wifi drivers from 13.10?

Also, I changed my wifi security from WPA2 to 128 WEP and so far I have only disconnected once in a few hours. On WPA2 it was every 10 on average.

  • Could it be because I am using the nox2apic kernel param? That was the only real systemish change I made. I use this to enable suspension. – Jordan Apr 24 '14 at 15:22
  • I wiped and re installed Ubuntu Vanilla 14.05 LTS. Stull seeing these errors in the syslog. – Jordan Apr 25 '14 at 12:10
  • If this happens with Live versions of the system I dare to say it's a bug, and going by your log I would be fairly sure. – Braiam May 5 '14 at 13:42
  • Yeah I think so too. I turned on Pre-released updates and hope a patch comes down the pipe soon. – Jordan May 9 '14 at 12:21
  • Everyone seem to say it is harmless, but for my connection, I never get connected back to the wifi. will try the different suggestions in the comments and see which of them resolves my issues. – kmassada Nov 1 '14 at 13:31
9

According to comments on launchpad, it's harmless:

WinEunuchs2Unix (ricklee518) wrote on 2014-08-18: #24

Oops this has been going on since 2009 and a developer did respond that it is simply for roaming in corporate environments with multiple access points to connect to. If you only have one AP at home go into network manager, select "Edit Connection", highlight your AP / wlan0 and click "Edit". Then click the down arrow next to BSSID which is blank. Then select the mac address that was hidden before.

My apologies for linking this to an 802.11n problem. Once bitten twice shy I guess....

I've done those steps and both the scan and error lines have stopped being logged. I can't yet say if it's made my connection more stable, but I'll try to remember to update this answer in a day or two.

I'm back 3 weeks later (had lost the open tab, oops), and I think it has helped. I still get the weird connection drops, but they don't seem nearly as common as I remember them being back when I first found this question.

| improve this answer | |
  • Thanks for the helpful notes. That workaround worked for me, but it only fixes one SSID at a time. And this is not "harmless", as the dozens of commentators on launchpad bug 1323089 have made clear. Spamming the syslog makes it hard to see other problems, wastes disk space, and above all wastes people's valuable time. It should be fixed! – nealmcb Apr 18 '15 at 16:27
3

I probably have the same issue, see "Frequent deauthentication from Wifi (Reason: 6) in a Centrino Advanced-N 6230 [Rainbow Peak]".

I think I found a workaround by disabling mode-N wifi. This can be done temporarily (after removing the module) with "modprobe iwlwifi 11n_disable=1" or permanently by adding "options iwlwifi 11n_disable=1" to some file in /etc/modprobe.d.

Maybe we should open a bug on bugzilla.kernel.org?

| improve this answer | |
2

@Jordan, I found a workaround i.e. stop network manager to avoid scanning for AP every 2 seconds which is where I think there is possibly a bug in wpa_supplicant driver code. Once I connect to my AP, I run the following...

sudo killall -STOP NetworkManager

Though I use wireless network on my desktop, it is stationary and I really don't need the NetworkManager constantly looking for APs and getting into this problem. Until this problem is fixed in the driver, I am going to continue with the above work around.

| improve this answer | |
  • That killed my whole network. I needed to stop network-manager and then start network-manager – Jordan May 1 '14 at 1:47
  • I tried checking off the pre-release updates in the update manager and updated the whole computer with the risky packages. Lets see what happens. – Jordan May 1 '14 at 1:49
0

It could be a bug in the Linux driver, or the access point firmware, or both. Does turning off power saving help? iwconfig wlan0 power off

To narrow down the problem you could try using a different access point and a USB wifi adaptor. Unfortunately these kind of problems are quite hard to diagnose.

| improve this answer | |
  • Thanks, I will try the power saving tip. I will try to wifi while at work, see if I get the disconnects. – Jordan May 5 '14 at 21:20

Not the answer you're looking for? Browse other questions tagged or ask your own question.