3

Here's the story:

I've upgraded from 12.04 (running alongside a Windows 7) to 14.04 from a DVD. I told it to delete the previous version completely, so it was technicaly a fresh install rather than an upgrade.

Everything seemed to work fine after the installation, so I played around a little and broke my desktop with some odd Compiz settings. I had no idea how to fix it quickly, so I decided to simply install Ubuntu again (and again deleting the previous version completely).

The installation ran through fine, but when it came to the reboot after the last step, I landed on a GRUB console:

                    GNU GRUB version 2.02~beta2-9

Minimal BASH-like line editing is supported. For the first word, TAB 
lists possible command completions. Anywhere else TAB lists possible 
device or file completions

grub> _

Oh well... After asking Google I assumed that this means that the bootloader doesn't know what to load.

So I entered the boot device selection on startup and saw this:

Boot device selecting screen

If I select "Internal HDD" in the Boot Manager, everything works fine - I get the purple GRUB screen and it even shows me my Windows 7. But having to call the boot manager on each start is not quite a solution.

So, wondering where the 2 Ubuntu entries came from, I took a look at the boot menu in the BIOS and found this:

BIOS Boot Menu

So as far as I understand it has something to do with GRUB and UEFI, but I don't know enough about any of it to put it all together...

So my question is: What's wrong here and how can I fix this?

When I shut down Ubuntu, it hangs on the purple screen, with the dots blinking, but even after 10 minutes nothing happens, so I have to switch it off. Rebooting works as expected, though.

Does it have something to do with the problem above?

  • What happens when you disable UEFI Boot? – Louis Matthijssen Apr 24 '14 at 10:49
  • @LouisMatthijssen Yep... That makes everything work as expected (even the shutdown!) :) But I don't quite understand why? What's wrong with UEFI? It was enabled before, why wouldn't it work now? – Quasdunk Apr 24 '14 at 10:54
  • I had the same problem, every cold boot would get me in GRUB rescue, until I re-ordered the boot order. Disabling Fast Boot solved this problem for me. Could you try if this works for you too? – Louis Matthijssen Apr 24 '14 at 11:05
  • @LouisMatthijssen The EFI entries are separate from the other ones, so I actually can't change the order, I just can disable UEFI and then it falls back to the 'normal' ones, and they already are in the right order. But I can't put any of them before UEFI while it's enabled. So I guess I'll just have to deal with the no-UEFI-thing... But I think that shouldn't be too big of a problem :) Please feel free to post your comment as an answer so I can accept it! – Quasdunk Apr 24 '14 at 11:22
1

You can set UEFI Boot to disabled to use legacy booting.

If you want to use UEFI you can try to disable Fast Boot, this solved the problem for me.

| improve this answer | |
0

I think you need to update and install grub freshly. Open the terminal and type

sudo apt-get update
sudo apt-get install grub

and this will install grub automatically to the required drives.

| improve this answer | |
  • I'm not sure if that's the right approach, grub isn't actually 'broken', I even see the right entries in /boot/grub/grub.cfg and everything works fine if I select a non-efi boot device. – Quasdunk Apr 24 '14 at 10:56
  • @Quasdunk Because I have got that black grub console screen once when I was messing up with windows installation alongside Ubuntu and installing the grub again made it normal. – ganezdragon Apr 24 '14 at 11:08
  • @Quasdunk Moreover you could give it a try! – ganezdragon Apr 24 '14 at 11:09
  • Ok, I gave it a shot, but still got the same results... Thanks anyway for your help! – Quasdunk Apr 24 '14 at 11:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.