18

I installed IntelliJ IDEA 13.1 and Oracle JDK 1.8 on Ubuntu 14.04 x64 but when I launch IntelliJ IDEA the font is not ideal.

How I can change the font?

screenshot

  • The font rendering in the screen shot looks ok to me. Are you running the native resolution of your screen with the correct sub-pixel anti-aliasing settings? – David Foerster Oct 25 '14 at 8:54
  • Note that Intellij uses the default java which typically is openjdk (which for some reason has inferior font rendering), unless you set the JAVA_HOME line in bin/idea.sh – Thorbjørn Ravn Andersen Jul 14 '15 at 8:43
27

I wrote a little manual how to fix this. Note: that it is only for 64-bit. architecture.

wget http://urshulyak.com:8001/index.php/s/P4afbWaX3mvyjP7/download &&
mv download jdk-8u5-tuxjdk-b08.tar.gz &&
tar -zxvf jdk-8u5-tuxjdk-b08.tar.gz &&
sudo mv jdk-8u5-tuxjdk-b08 /usr/lib/jvm &&
rm jdk-8u5-tuxjdk-b08.tar.gz

Script to start Intellij Idea

*only note that need to change IDEA_HOME location for your path of idea

#!/bin/sh

IDEA_HOME=/opt/idea
# for old idea JAVA_HOME, for new 2016+ will be IDEA_JDK
#export JAVA_HOME=/usr/lib/jvm/jdk-8u5-tuxjdk-b08/

export IDEA_JDK=/usr/lib/jvm/jdk-8u5-tuxjdk-b08/
export _JAVA_OPTIONS="-Dawt.useSystemAAFontSettings=lcd \
                      -Dsun.java2d.xrender=true"
export GNOME_DESKTOP_SESSION_ID=this-is-deprecated
exec $IDEA_HOME/bin/idea.sh "$@"

More info and screenshots of better fonts: http://urshulyak.com/page/show/2. Result:

  • Can you update the link please? – Jose Elera Sep 9 '14 at 21:25
  • 1
    Note that -Dawt.useSystemAAFontSettings=lcd is a noticeable improvement over -Dawt.useSystemAAFontSettings=on on my LCD monitor and laptop screen. – John McFarlane Dec 5 '14 at 1:52
  • I still couldn't find the Monaco font in the dropdown, though it's installed on my system. – Apurv Jan 4 '16 at 7:49
  • 5
    If you are using IDEA 2016.1 set IDEA_JDK instead of JAVA_HOME – Pietro Mar 21 '16 at 9:23
  • I've downloaded 70 MB file just to know that, it is for amd64 architecture! A bad answer. – Anwar Mar 26 '16 at 11:37
8

Short answer that worked for me:

1) Go to File->Settings->Appearance & Behavior->Appearance.

2) Under anti-aliasing change both IDE and Editor options to "Greyscale".

  • 1
    In my case (IntelliJ 15.0 Community Edition, Ubuntu 15.04 and Open-JDK) this solution worked perfectly. – 0x450 Nov 22 '15 at 13:35
  • 1
    Intellij 15.0.2 Community Edition, Oracle JDK 8, Ubuntu 14.04.3 - Out of all the solutions proposed here, only this worked for me. – thefourtheye Dec 25 '15 at 4:02
  • 1
    This was the best solution for me on Android Studio 2.0 – molokoka Apr 8 '16 at 10:36
  • 1
    this solution actually work for me as well. Thanks – Ashish Apr 11 '16 at 1:28
  • 1
    Worked perfectly! :D – Akar Sep 17 '16 at 10:09
4

Don't apply this configuration on Ubuntu 14!

Install freetype

$ sudo apt-get install libfreetype6

Install infinality patch

$ sudo add-apt-repository ppa:no1wantdthisname/ppa
$ sudo apt-get update
$ sudo apt-get install fontconfig-infinality

I had to do the following afterwards:

$ sudo rm /etc/fonts/conf.avail/52-infinality.conf
$ sudo ln -s /etc/fonts/infinality/infinality.conf /etc/fonts/conf.avail/52-infinality.conf

To use Windows 7 like font rendering do the following:

$ sudo /etc/fonts/infinality/infctl.sh setstyle win7

Configure your IDEA_HOME/bin/idea64.vmoptions. Add below lines:

-Dawt.useSystemAAFontSettings=on
-Dswing.aatext=true

Also enable Use Anti-aliased font checkbox, go to: File -> Settings -> Editor -> Appearance.

Preview:

Editor font: Monaco, UI: Ubuntu Bold

enter image description here

  • I create screenshot. i61.tinypic.com/jg63pi.png – Silvestr Apr 27 '14 at 16:15
  • This actually broke my ubuntu fonts on 14.04. – Lilley Oct 7 '14 at 23:09
  • It broke my system fonts too!! – n3o Nov 19 '14 at 1:00
  • @n3o You use Ubuntu 14.04 ? – Anton Dozortsev Nov 19 '14 at 11:55
  • Broke my ubuntu fonts on 14.04. shame. do not use this! – zeal Feb 26 '15 at 14:34
4

I have prepared a dedicated font named as "Ubuntu Mono Nohinting" to workaround a rendering issue with Java Swing applications such as NetBeans IDE, IntelliJ IDEA and PyCharm. The font hinting information has been stripped from the original Ubuntu Mono font family.

How to install

  • download the zip file from here
  • extract it
  • open *.ttf with Font Viewer to install.
  • or you can manually copy *.ttf into ~/.local/share/fonts/.

How to use

  • Select "Ubuntu Mono Nohinting" in editors' configuration.

Screenshots

Ubuntu Mono Font with PyCharm Monokai theme

Ubuntu Mono Font with PyCharm Monokai theme

Ubuntu Mono Nohinting Font with PyCharm Monokai theme

Ubuntu Mono Nohinting Font with PyCharm Monokai theme

  • Can you strip hinting information form Liberation Mono font too? – sasa Sep 4 '15 at 9:21
  • Great initiative! but looks even odder on my Ubuntu (intelliJ IDEA) – matt Nov 7 '15 at 7:26
2

Note that in Webstorm 9, the file you need to add these changes:

-Dawt.useSystemAAFontSettings=on
-Dswing.aatext=true

is:

bin/webstorm64.vmoptions

Confirmed working on Ubuntu 14.04

1

At startup before opening a project go to Configure -> Settings -> Appearance and tick override default font checkbox, select font and size (I highly recommend Dejavu Sans Mono 14px, everywhere)

0

You can change the font used by IntelliJ. To do that:

  • Select the File menu, and choose Settings -> Editor -> Colors & Fonts -> Font.
  • Click on Save As in the right-hand pane and enter a name for your new Scheme
  • Change what is selected under Primary Font
  • Click Apply
0

As mentioned in an answer above, using jdk-8u5-tuxjdk-b08.tar.gz fixed the problem for me while using Ubuntu 16.10 and IntelliJ 2016.

One smarter way of configuring the above mentioned jdk as IDE boot JDK (once it is downloaded and extracted) is using Intellij's "Quick Action" Ctlr + Shift + A and search for Switch IDE Boot jdk. Browse the extracted jdk and restart IntelliJ !

0

You can download IntelliJ Idea with a custom embedded OpenJDK which includes font rendering fixes.

Bundled OpenJDK fixes a lot of font rendering issues that will be fixed only in Java 9.

https://intellij-support.jetbrains.com/hc/en-us/community/posts/205418410/comments/204844430

Sometimes (as in the case of 171.3780.107) font rendering fixes didn't work and I had to copy the embedded jre of the previous version (simply copy the jre folder).

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.