5

This really make me struggle , I have upgrade my dell xps13 9333 from ubuntu 13.10 to 14.04, now I could never connect to the wifi at home. The wifi card can see the wireless network, but cannot connect to it, sometimes it does, but if I ping some external server in the internet, it disconnected the wifi automatically, I have also tried the ubuntu gnome 14.04, it keeps asking the wifi's password, and still cannot connect to the internet. But the laptop can connect to the open wifi in my company, which make me crazy, I cannot figure out which part is wrong.

The encryption of my home is WPA/WPA2 Personal.

Any one can help could be very appreciate.

  • I have the same problem pls help! When i do a hotspot with my phone i can connect to it but not to my wifi or the extender. I don't know why the Hotspot works.. – user274211 Apr 25 '14 at 16:17
  • Hi & Welcome to AU. Please see whether this helps > Can't connect to wireless 13.10. Let me know if it helped you – AzkerM Apr 27 '14 at 15:06
1

What you wanna do is go into start menu>preferences>default applications for LX sessions. The click on the autostart tab.There is a small text input box with an ADD button next to it. Type in nm-applet and then click add, right next to the text input box. Then logout and log back in again. That should do the trick. Comment back to let me know how it went.

0

I had the same issue here on my xps13 9333.

After doing the following I had no more dropoff since some hours. Looks like this fixed it so far.

1st: I installed new wifi firmware which you can download here:

http://wireless.kernel.org/en/users/Drivers/iwlwifi#Download

once you downloaded the file matching your kernel and device (should be: Intel Wireless 7260) you can extract and then copy the *.ucode file to /lib/firmware by using:

cp iwlwifi-*.ucode /lib/firmware

2nd: I also updated the Bios Version which was A02 to A04 follwing these steps (which you can find here: http://randomtristan.blogspot.de/2013/01/my-review-of-dell-xps-13-developer.html)

  1. Insert a blank USB drive. Any size will do. I used an ancient 64 MB drive. (Yes, that really is an M.)

  2. Install UNetbootin from the Ubuntu Software Center and open it.

  3. Select FreeDOS 1.0 and the USB drive, then click OK. It will create a bootable FreeDOS LiveCD on the USB drive.
  4. Download Dell's BIOS update EXE file and save it to the USB drive's root (it is a single executable for both Windows and DOS). (find Bios update here: http://www.dell.com/support/drivers/us/en/04/ServiceTag/DRVX002)
  5. Reboot and press F12 to get into the (current) BIOS's boot menu.
  6. Select the USB drive and press Enter.
  7. You will get a UNetbootin boot menu with a single entry named "Default". Press Enter to select it and continue.
  8. Now you will get a FreeDOS boot menu. Be very careful not to choose the default option. That will install FreeDOS to your hard drive. You don't want that. Instead, choose the option to run FreeDOS as a LiveCD, without HIMEM or EMM386.
  9. Now you have a DOS prompt! Type "c:" and press enter to change to the C drive, which is in fact the USB drive.

  10. Type "dir" and press enter to see the contents, which should include the Dell BIOS updater file that you copied to the USB drive.

  11. Type the name of the BIOS updater file and press enter to run it. The BIOS updates automatically and the computer will then reboot.

  12. Re-run "sudo lshw | grep -A 4 BIOS" in Ubuntu to verify that you really do have the new BIOS version now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.