8

I used auto-mount option in Ubuntu 14.04 for mounting my all drives at startup.

enter image description here

All drives mounts automatically on startup except /dev/sda3. (Let me clarify that /dev/sda3 is ext4 file-system and labeled Ext4).

It gives error on startup and ask S for skip and M for manual mounting.I skipped and try to mount with disk (installed app from dash earlier disk-utility), it gives error:

enter image description here

But If I mount with command: sudo mount /dev/sda3 /media/pandya/Ext4 at startup (By pressing M for manual mount) or after started up (from terminal), then it mounts properly.

Gparted also mounts that drive on /media/pandya/Ext4 Successfully.

I also checked /etc/fstab and entry for /dev/sda3, which is proper

/dev/sda3 /media/pandya/Ext4 auto nosuid,nodev,nofail,x-gvfs-show 0 0

I used same auto-mount options for all drive. Then why only one is not auto-mounting?

  • Is there any information in dmesg? As the error says, try dmesg|tail. – Jos Apr 24 '14 at 6:43
  • @Jos [ 75.112360] EXT4-fs (sda3): Unrecognized mount option "x-gvfs-show" or missing value – Pandya Apr 24 '14 at 6:53
  • 9
    I found a bug relevant to this issue. As a workaround, edit the fstab to show "comment=x-gvfs-show" instead of "x-gvfs-show". – Jos Apr 24 '14 at 7:00
  • It would be helpful for other users accepting a working answer. Cheers. – Atcold Aug 3 '15 at 17:58
  • @Jos: What does comment=x-gvfs-show do? Or just x-gvfs-show for that matter? I had x-gvfs-show inserted automatically as an option in /etc/fstab when editing (or rather creating) the mount options of an ntfs partition using the application Disk in Linux Mint (probably also an Ubuntu application). – HelloGoodbye Feb 3 '16 at 20:00
7

As @Jos suggested, this is the bug Bug #1012081: util-linux needs updating to 2.24.2 and can be fixed by adding comment= in front of x-gvfs-show.

enter image description here

4

Uncheck Show in user interface.

It boots and mounts properly, but is not visible in the nautilus file explorer.

  • This actually worked. Amazing. – gruszczy Nov 14 '14 at 21:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.