3

I upgraded from 13.10 to 14.04, and when I restarted the computer and selected Ubuntu, the black screen said:

mount: mounting/dev/loop0 on/root failed: Invalid Argument
mount: mounting/dev on/root/dev failed: No Such File or Directory
mount: mounting/sys on/root/sys failed: No Such File or Directory
mount: mounting/proc on/root/proc failed: No Such File or Directory
Target Filesystem doesn't have requested /sbin/init.
No init found. Try passing init=bootarg.
BusyBox v.1.21.1 (Ubuntu1:1.21.0-1ubuntu1)built-in shell(ash)
Enter 'help' for a list of built-in commands.
(initramfs)_

Can anyone help me fix this?

1
  • This solved the problem, I see the desktop but it keeps loading without entering Ubuntu environment Aug 19 '14 at 17:43
3

I had the same problem this morning, after my 13.10 to 14.04 upgrade last night. My setup is a dual boot with Windows, using the windows boot manager.

I found the solution here: same issue with Win 8

The precis is:

  1. When I select Ubuntu from the boot manager, I hold the shift key
  2. This brings up Grub manager
  3. With the first line selected, hit "e" (for edit)
  4. Hunt down through the boot instructions to a long command line that includes options "ro quiet splash"
  5. Change the "ro" to "rw" (readonly to read-write)
  6. ctl-x to save and run

This brought me right up in 14.04 LTS. The disclaimer is that I don't have any idea why it worked. I then edited /boot/grub.cfg to make this same change permanent (suggestions on the correct way to do this appreciated).

1
  • well dang, I have no idea how you figured that out, but it works! I was on wubi if that makes any difference...
    – Blaine
    Jul 22 '17 at 0:00

Not the answer you're looking for? Browse other questions tagged or ask your own question.