3

I already installed a program called CadFeko, and I can run it from terminal. To run the program, first I have to run this command

     . /opt/feko/6.3/bin/initfeko

Then I can call the program by

     cadfeko

This doesn't release the terminal. Also, if I close the program and terminal I have to run the initfeko again.

I tried to create a shortcut launcher for this program. I cannot figure it out, how can I use combination of these two commands on the same line. I already tried something like this in my .desktop file:

   Exec=  . /opt/feko/6.3/bin/initfeko && cadfeko

but this is not working for me. Please let me know if there is a solution for this.

Thanks.

4

You could try this Exec line for your .desktop file:

Exec= bash -c ". /opt/feko/6.3/bin/initfeko && cadfeko"

bash will open a shell and correctly interpret the &&.

  • TX for the comment. This wasn't working last week. I tried again now and works fine. TX again :) – antmw1361 Apr 29 '14 at 11:23
1

Use this command:

. /opt/feko/6.3/bin/initfeko && cadfeko &

adding '&' at the end will let it run in the background the terminal auto hides

I hope that works

  • Thanks, This works fine in terminal, but I had no luck with launcher so far :( – antmw1361 Apr 24 '14 at 9:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.