I will start with a disclaimer: I have been using Xubuntu for a few years now, but I would still consider myself a beginner.

When I first installed(12.04) my computer detected that there were additional drivers available for my Nvidia card (a geforce 540 at the time).

When the proprietary drivers came out (304?) I had to install them manually every time because the install from additional drivers would fail (sudo sh NVIDIA-...)

Something happened about 6 months ago, and they began showing up on my updates and being convenient. I assume that means I had added a repository, but I have no idea which one.

I recently upgraded to a Geforce 750Ti, and at the same time tried to upgrade to 14.04 (from 12.10)

The update went bad, and I had to reinstall. The newer installation cd wouldn't even load without the nomodeset option.

I no longer have my proprietary drivers, and am currently stuck with a 800x600 resolution.

I tried installing nvidia-current with the package manager. It says that it installs them, but then it doesn't seem to use them.

I have also tried installing the binary drivers directly. (This gave me a lot of errors and did not work).

I know that at one point steam was notifying me of the drivers and offering to enable them in the past. I tried installing steam to see if that could be a method, but steam failed to launch with an error about not having OpenGL.

I don't get why it isn't giving me the option to install from "additional drivers" if I can get nvidia-current via apt-get.

I have probably spent about 10 hours at this point looking, but haven't found a solution that worked for my situation.

Please forgive me if this is an extremely stupid question, and thanks in advance for any help you can give.

sudo apt-get install linux-headers-3.13.0-19-generic ubuntu-restricted-*

Install driver from Additional drivers.

"If the activation hangs on download/install dialogue, you can install the driver using System -> Administration -> Synaptic Package Manager, make sure you pick the latest driver version recommended by the Additional Drivers tool and all its dependencies. Then go to the Additional Drivers tool and activate the driver you just installed."

Retrieved from https://help.ubuntu.com/community/BinaryDriverHowto/Nvidia

Would definitely read all the info there to be aware of all the potential issues and there fixes.

  • sudo apt-get install linux-headers-3.13.0-19-generic ubuntu-restricted-* [sudo] password for : Reading package lists... Done Building dependency tree Reading state information... Done Note, selecting 'lubuntu-restricted-extras' for regex 'ubuntu-restricted-*' E: Unable to locate package linux-headers-3.13.0-19-generic E: Couldn't find any package by regex 'linux-headers-3.13.0-19-generic It said each of the variants in the middle but I cut them to save characters. – vaknah Apr 24 '14 at 1:36
  • Synaptic might help, it fixes broken packages too. But, I just checked and they pulled that package out of the repository, it's a PPA now. :( – ubuntu1up Apr 24 '14 at 1:57

I found a solution:

It turns out that Geforce 750Ti support was not added to the nvidia drivers until 334.

I had to add the xorg-edgers ppa

$ sudo add-apt-repository ppa:xorg-edgers/ppa -y
$ sudo apt-get update

Then I used Synaptic Package Manager to install nvidia-334

Thanks ubuntu1up for pushing me the right direction and to this guide that I used to get the ppa, and general solution.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.