I'm trying to use LibreOffice 3.4 RC 1 on my system, and at first it was working fine. However when I tried to save a file in writer, it kept failing, so I tried to restart, but found it would no longer launch.

It turns out I've been hit by a bug that was supposedly fixed in RC 1, and according to comments, I shouldn't be seeing this problem, so I'm guessing it might be Ubuntu specific (just guessing).

The reason for this questions isn't so much to get it working (though that would be great), but rather to help me rule out the possible causes (such as Ubuntu not being compatible with something along the way).

Below this the commandline output:

Warning: failed to launch javaldx - java may not fuction correctly /opt/libreoffice3.4/program/soffice.bin: error while loading shared libraries: libjvmfwk.so.3: cannot open shared object file: No such file or directory

  • @roland-taylor: If you have just installed it, try to run sudo ldconfig to update the shared libraries symlinks – sebikul May 26 '11 at 20:58
  • @sebikul that doesn't work. – RolandiXor May 26 '11 at 21:04
  • @roland-taylor: here you have a workaround, it should work until it gets fixed upstream – sebikul May 26 '11 at 21:21
  • @sebikul, thanks. I will give this a shot. Btw can you post that as an answer (in detail)? – RolandiXor May 26 '11 at 21:23

Here is what you should do:

  1. Run: locate libjvmfwk and copy the full path without the filename.

    eg: if the output is /usr/lib/ure/lib/libjvmfwk.so.3 write down /usr/lib/ure/lib)

  2. Run gksudo gedit /etc/ld.so.conf.d/libjvmfwk.so.3.conf and add the path you wrote down in the first step to the end of the file. (Please note that the file will be created if it does not exist)

  3. Finally run sudo ldconfig to update the symlinks


  • this worked, after I used a custom path that is ;) – RolandiXor May 26 '11 at 21:48
  • @roland-taylor: glad it worked. Thanks for editing the answer – sebikul May 27 '11 at 1:44
  • it has one problem though: it causes problems with firefox, so I have to disable it when I'm not using LibreOffice. – RolandiXor May 27 '11 at 3:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.