1

I want to use gnucash. However I am not familiar with the English terminalogy regarding finance. Now I wanted to start gnucash with the Dutch translation, which I believe is available for 2 reasons. Firstly the gnucash site is also in Dutch, and secondly when I look to the wiki regarding starting gnucash with a different language I see also the Dutch translation been specified.

The problem I have is that I cannot seem gnucash to startup with the Dutch translation using LANGUAGE=nl_NL.UTF8 LANG=nl_NL.UTF8 gnucash

Checking locale -a, I obtain:

C 
C.UTF-8 
en_AG 
en_AG.utf8 
en_AU.utf8 
en_BW.utf8 
en_CA.utf8
en_DK.utf8 
en_GB.utf8 
en_HK.utf8 
en_IE.utf8 
en_IN 
en_IN.utf8 
en_NG
en_NG.utf8 
en_NZ.utf8 
en_PH.utf8 
en_SG.utf8 
en_US.utf8 
en_ZA.utf8
en_ZM 
en_ZM.utf8 
en_ZW.utf8 
nl_AW 
nl_AW.utf8 
nl_BE.utf8 
nl_NL.utf8
POSIX

So why don't I get gnucash to startup with the Dutch language?

-edit- I installed all the Dutch language packages by

sudo apt-get install language-pack-nl language-pack-gnome-nl language-pack-nl-base language-pack-gnome-nl-base

Still no success unfortunately. However when I now tried to startup gnucash using LANGUAGE=nl gnucash I didn't get the warning The locale defined in the environment isn't supported. Falling back to the 'C' (US English) locale. However gnucash was still in English.

-edit2- Output of locale

LANG=nl_NL.UTF-8
LANGUAGE=nl:en
LC_CTYPE="nl_NL.UTF-8"
LC_NUMERIC=nl_NL.UTF-8
LC_TIME=nl_NL.UTF-8
LC_COLLATE="nl_NL.UTF-8"
LC_MONETARY=nl_NL.UTF-8
LC_MESSAGES="nl_NL.UTF-8"
LC_PAPER=nl_NL.UTF-8
LC_NAME=nl_NL.UTF-8
LC_ADDRESS=nl_NL.UTF-8
LC_TELEPHONE=nl_NL.UTF-8
LC_MEASUREMENT=nl_NL.UTF-8
LC_IDENTIFICATION=nl_NL.UTF-8
LC_ALL=
0

Since gnucash is a GNU application, it uses the LANGUAGE variable.

LANGUAGE=nl gnucash

is what you want.

The reason why

LANGUAGE=nl LANG=nl gnucash

does not work is that LANG requires a valid locale name, which nl is not, so you broke your locale and it used the fallback language English.

  • I tried LANGUAGE=nl LANG=nl gnucash which gave me The locale defined in the environment isn't supported. Falling back to the 'C' (US English) locale. I also tried LANGUAGE=nl gnucash which gave me the same result The locale defined in the environment isn't supported. Falling back to the 'C' (US English) locale – WG- Apr 23 '14 at 19:59
  • @WG-: In that case the locale in your environment is broken. What does the locale command output? – Gunnar Hjalmarsson Apr 23 '14 at 20:34
  • see edit in openings post. – WG- Apr 23 '14 at 20:46
  • @WG-: Well, that looks correct. And no error messages? In that case I don't understand why LANGUAGE=nl gnucash didn't work. It worked for me. Btw, it might be important that the command is not preceeded by invalid LANG settings. Open a new terminal window and start with the correct command. – Gunnar Hjalmarsson Apr 23 '14 at 22:07
  • @WG-: It just struck me.. That locale output shows that your display language is Dutch already, so just starting with gnucash should give you Dutch - just as with all other programs. – Gunnar Hjalmarsson Apr 23 '14 at 22:24
0

The gnucash-common package appears to only have plain nl as a translation for Dutch. I am not sure why, but it appears that the loading of translations is not falling back to that as an option.

However, running LANGUAGE=nl_NL.UTF-8 ANG=nl_NL.UTF-8 gnucash in the terminal, does seem to work for me. Is one of these variables not set correctly in your environment? Are you missing a language-pack package that may be required for the translations to work in your language in gnucash? You may need language-pack-gnome-nl-base installed for it to work.

  • Well I also tried using LANGUAGE=nl LANG=nl gnucash but that didn't work either. – WG- Apr 23 '14 at 19:19
  • in response to your edit, I also did install language-pack-gnome-nl-base and all other Dutch languages packs however that did not help :-( – WG- Apr 23 '14 at 20:03
0

I had a similar issue with gnucash - finally i found the solution in the wiki:

Notes for Ubuntu users

If the previous instructions don't works, please check the following items:

if you have installed localepurge package, be sure that the locale you are using is not deleted after the installation of gnucash. To check this, reconfigure localepurge, and be sure to not include your locale in the list of the ones to be deleted

sudo dpkg-reconfigure localepurge

Then reinstall all gnucash packages:

sudo apt-get install --reinstall gnucash gnucash-common gnucash-doc

In my case (LANG=de_DE), the de_DE entry was already excluded, but additionally i had to exclude the de entries, too. So, you may have to exclude the nl entry from localpurge, too.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.