I am trying to upgrade from lubuntu 13.10 to 14.04 using

apt-get update
apt-get dist-upgrade  

However the last command returns No new release found

I also tried do-release-upgrade -d with the same result.

/etc/apt/sources.list looks like:

# deb cdrom:[Lubuntu 13.10 _Saucy Salamander_ - Release amd64 (20131016.1)]/ saucy main multiverse restricted universe

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://de.archive.ubuntu.com/ubuntu/ saucy main restricted
deb-src http://de.archive.ubuntu.com/ubuntu/ saucy main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://de.archive.ubuntu.com/ubuntu/ saucy-updates main restricted
deb-src http://de.archive.ubuntu.com/ubuntu/ saucy-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://de.archive.ubuntu.com/ubuntu/ saucy universe
deb-src http://de.archive.ubuntu.com/ubuntu/ saucy universe
deb http://de.archive.ubuntu.com/ubuntu/ saucy-updates universe
deb-src http://de.archive.ubuntu.com/ubuntu/ saucy-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://de.archive.ubuntu.com/ubuntu/ saucy multiverse
deb-src http://de.archive.ubuntu.com/ubuntu/ saucy multiverse
deb http://de.archive.ubuntu.com/ubuntu/ saucy-updates multiverse
deb-src http://de.archive.ubuntu.com/ubuntu/ saucy-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://de.archive.ubuntu.com/ubuntu/ saucy-backports main restricted universe multiverse
deb-src http://de.archive.ubuntu.com/ubuntu/ saucy-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu saucy-security main restricted
deb-src http://security.ubuntu.com/ubuntu saucy-security main restricted
deb http://security.ubuntu.com/ubuntu saucy-security universe
deb-src http://security.ubuntu.com/ubuntu saucy-security universe
deb http://security.ubuntu.com/ubuntu saucy-security multiverse
deb-src http://security.ubuntu.com/ubuntu saucy-security multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu saucy partner
# deb-src http://archive.canonical.com/ubuntu saucy partner

## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
deb http://extras.ubuntu.com/ubuntu saucy main
deb-src http://extras.ubuntu.com/ubuntu saucy main

deb http://ppa.launchpad.net/stebbins/handbrake-releases/ubuntu raring main
deb-src http://ppa.launchpad.net/stebbins/handbrake-releases/ubuntu raring main
deb http://dl.google.com/linux/earth/deb/ stable main
# deb-src http://archive.canonical.com/ubuntu saucy partner

Note that I just upgraded lubuntu another using the same servers without problems.

File contents of /etc/update-manager/meta-releases

# default location for the meta-release file

URI = http://changelogs.ubuntu.com/meta-release
URI_LTS = http://changelogs.ubuntu.com/meta-release-lts

/etc/update-manager/release-upgrades looks like:

# some comments...


I also changed normal to lts without success.

I also checked the directory /var/lib/ubuntu-release-upgrader/ which is empty.

There is also no proxy file in /etc/apt/apt.conf.d/ so no proxy seems to be used.

The file /etc/hosts looks like:       localhost       mybox

# The following lines are desirable for IPv6 capable hosts
::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

So I tried every solution from Distribution upgrade problem "No new release found" without success.

Any idea what may be wrong here?


Using the graphical interface update-manager I got the error message: "Failed to download repository information"

Perhaps this gives you a hint how to solve the problem.


I now changed from the de servers to the main servers and removed all ppas from my sources.list and sources.list.d. If possible using ppa-purge. If not I purged the relevant packages with aptitude and then removed the ppa-entries.

The ppa's where about following packages: sagemath, google-earth, handbrake, freetuxtv and julia (a math program).

However without success.


6 Answers 6


For me the reason was that I had disabled the automatic checking for upgrades, as the check-new-release process kept significantly slowing down my computer.

Changing back to Prompt=normal in /etc/update-manager/release-upgrades instantly fixed the problem.

  • 2
    This worked for me. It was set to "lts" before and by setting it to "normal", it has found the trusty upgrade. Commented Oct 5, 2015 at 22:19
  • 2
    Thanks, this solved it for me too - presumably LTS versions only look for new LTS versions, so you can't just upgrade to the latest without this change.
    – Jon Story
    Commented Oct 10, 2015 at 21:11

It finally worked. The problem was that I did do-release-upgrade as root, this didn't work. Invoking this command as normal user worked. Hower I don't understand why it doesn't as root.


Try This!!!

Cut and paste entire set of below commands :

sudo apt-get clean ;
cd /var/lib/apt ;
sudo mv lists lists.old_`date '+%Y%m%d_%H%M%S'`   ;
sudo mkdir -p lists/partial ;
sudo apt-get clean ;
sudo apt-get update

The semicolon demarcates each command so they can be pasted together. After that do this:

sudo apt-get clean
sudo do apt-get update
sudo apt-get dist-upgrade  
sudo do-release-upgrade

If that fails, then do this:

sudo sed -i 's/saucy/trusty/g' /etc/apt/sources.list
sudo apt-get update
sudo apt-get upgrade 

Note: Remove All third party PPAs unless they have an 14.04 version available. If you have the Gnome PPA remove it with PPA-Purge.

  • 2
    Thanks. All steps before replacing saucy by trusty fail. But I am not sure if I should really try your last step. Does this lead to a safe upgrade? Doing apt-get dist-upgrade should then upgrade many packages since the sources are now trusty sources. I also commented out all ppas but didn't use ppa-purge, but I guess this should not make any difference...
    – student
    Commented Apr 24, 2014 at 8:30
  • 1
    @student I had the same problem few days ago... I did this, this way. It did breck my system because I did use the Gnome Remix with the Gnome PPA, and on their PPA page on Luchpad it says to not do it, to remove it with ppa-purge.
    – MathCubes
    Commented Apr 24, 2014 at 8:33

You need to check this option:

enter image description here

Then launch do-release-upgrade again

  • 1
    YES YES YES thanks this is the first thing that worked for me after hours of struggle. All the other checkboxes are disabled because 13.10 is EOL now and I had to manually change the apt-get sources (help.ubuntu.com/community/EOLUpgrades) but it kept saying there was no new release until I changed the "notify" setting as you said.
    – Lambart
    Commented Sep 6, 2015 at 4:43

Run the command: gksu update-manager -d from terminal or unity launcher. If you try running, sudo update-manager -d, it does not always give 14.04 available option. But with gksu, this option will appear.

Otherwise, create bootable USB drive. Boot using same and when installing, select upgrade or something else. In something else, give same drives as earlier as mount points for /, swap. De-select format option. Do not select format. This retains your all files and previous settings and does upgrade.

Thank you.

  • 2
    I get the message that my software is up to date. By the way: why should gksu give a different result than sudo?
    – student
    Commented Apr 24, 2014 at 9:17
  • 1
    Finally after trying lots of stuff, 'gksu update-manager -d' saved the day. BTW, gksu was not installed in my system. So first I had to apt-get install it and then run it. Commented Sep 16, 2014 at 17:57

I've also been plagued with "No new release found" recently and it turned out to be a connectivity issue. The request was being block by our firewall based on this Snort/Suricata rule:

ET POLICY Python-urllib/ Suspicious User Agent

I know this wasn't your issue, but hopefully it helps another.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .