29

I was trying to create an WiFi hotspot for my android device. I used ap-hotspot to do so.

I configured the ap-hotspot using

sudo ap-hotspot configure

Then I started ap-hotspot using

sudo ap-hotspot start

Then it shows this

Starting Wireless Hotspot...

And then nothing happens, no further message is displayed, hotspot is not created.

What is Wrong? How to fix it?

  • After following above steps, ap-hotspot was not working – user308833 Jul 24 '14 at 18:19
  • use the instructions below as given in the answer,. then configure the ap-hotsot and start,. it should work. – rajan Jul 25 '14 at 4:33
21

ap-hotspot uses hostapd to create wireless network

I had problems creating hotspot using hostapd in Ubuntu 14.04 mainly because new version of hostapd in 14.04 default repository is buggy.

You can solve this problem by downgrading hostapd in Ubuntu 14.04 LTS to a previous version

Uninstall buggy hostapd using apt-get:

sudo apt-get remove hostapd

Then install non-buggy version of hostapd:

  • 64 - bit:

    cd /tmp
    wget http://old-releases.ubuntu.com/ubuntu/pool/universe/w/wpa/hostapd_1.0-3ubuntu2.1_amd64.deb
    sudo dpkg -i hostapd*.deb
    sudo apt-mark hold hostapd
    
  • 32 - bit:

    cd /tmp
    wget http://old-releases.ubuntu.com/ubuntu/pool/universe/w/wpa/hostapd_1.0-3ubuntu2.1_i386.deb
    sudo dpkg -i hostapd*.deb
    sudo apt-mark hold hostapd
    

"sudo apt-mark hold hostapd" will prevent hostapd to upgrade to the buggy version.

Then try running ap-hotspot again, I think it should work. It worked for me like a charm.

  • what is this, it fills up the terminal. bash: notify-send: command not found – rajan Apr 23 '14 at 18:44
  • 2
    install notify-send using sudo apt-get install libnotify-bin – Back.Slash Apr 23 '14 at 18:57
  • if you use the "sudo apt-get upgrade" will the hostapd upgraded? – rajan Apr 24 '14 at 3:55
  • 1
    This solution not working for me. I have done everything as above. Still getting same problem. – Durgesh Suthar Jul 20 '14 at 10:07
  • 1
    If you can't get ap-hotspot to work, try kde-nm-connection-editor. It actually works. Here's a tutorial: ubuntuhandbook.org/index.php/2014/06/… – Lars Nyström Sep 11 '14 at 17:49
1

Install the hostapd as mentioned above, followed by ap-hotspot, from http://www.ubuntuupdates.org/package/webupd8/trusty/main/base/ap-hotspot and run

sudo ap-hotspot configure

Give the correct inter-phase eth0 and wlan0 followed by ssid and pass-phrase.

Start the hotspot by

sudo ap-hotspot start
0

The file:

http://archive.ubuntu.com/ubuntu/pool/universe/w/wpa/hostapd_1.0-3ubuntu2.1_amd64.deb

Is no longer present on the ununtu.com server. How do I upgrade the hostapd?

0

this is old post but i stuck in same problem and i solved my problem .

this problem may be occurs with wrong version but in my case if you are using any other network manager tools and service of that manager is running then it may not work ap-hotspot service and it show

 Starting Wireless Hotspot... 

solution: stop service of previous network manager tools if you are using default network manager then do

sudo service network-manager stop

or if you using wicd then stop it using

sudo service wicd stop

then you have to start ap-hotspot

sudo ap-hotspot start

protected by Community Oct 24 '14 at 14:57

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.