5

I started out with a fresh install of Ubuntu 14.04 server set up on a 10GB LVM partition. The only other thing I did was to then install the xen-hypervisor:

sudo apt-get install xen-hypervisor-amd64

I double checked that my hardware could support it (MSI Z87I motherboard and Intel i5-4570S cpu) and that I had virtualization set in the BIOS. I also double checked that GRUB defaults to boot into xen and that the xen toolchain is set to xl (not that that would likely cause my problem).

However, my system enters an endless cycle of booting up and rebooting until I tell GRUB to boot into regular Ubuntu. Here are the only things that show up whenever it tries booting into xen:

Loading Xen 4.4-amd64 ...
WARNING: no console will be available to the OS
Loading Linux 3.13.0-24-generic ...
Loading initial ramdisk ...

And then it reboots the system. Is there any error logs to check or any other boot parameters to try (the parameters are still set to the default)? Is it related to the above WARNING?

Edit: I gave up since there was nothing to go on and ended up dual-booting Windows and Ubuntu. I'd be willing to re-install on another partition if anyone has any ideas however.

  • Which tutorial have you followed to install xen? Here is a helpful one, see if this helps. – jobin Apr 23 '14 at 18:12
  • That's the one I used. It's outdated, but it basically does exactly what I said. It runs apt-get install and then changes the grub file and the xen toolchain; those two changes seem to be part of the actual install now, but I double checked to be safe as described in my post. – ubomb Apr 23 '14 at 18:15
  • The problem is right after that when it tells you to reboot. It simply won't boot into xen and endlessly reboots. – ubomb Apr 23 '14 at 18:16
  • You have a chance to see the error causing this when adding in /etc/default/grub file the line GRUB_CMDLINE_XEN="noreboot". In my case it showed my errors I did not see before. I could not solve it, but at least it is a lot more informative than "Loading initial ramdisk..." – CatMan May 10 '18 at 13:25
2

Someone suggested to set my BIOS to do legacy booting, so I put my BIOS in Legacy+UEFI mode. It didn't work, so I thought maybe Ubuntu had to be installed without the extra UEFI boot files, but I never got a chance to. Before I left for the weekend, I booted into Windows to do some work. I randomly decided to run my motherboard's updating program (Windows only - luckily I just bought Windows) which was taking hours, so I just left it running. Came back after the weekend, and it just worked! Specifically, I updated my BIOS from version 1.00 to 1.60.

For whoever is unlucky enough to have the same exact problem: link to BIOS upgrade tool.

1

If you want to check the error logs, mount the LVM and check if there's some in /var/log/.

BTW, Xen server works fine in my VMware VirtualMachine.And the same with VirtualBox VM.

http://blogs.citrix.com/2011/01/23/xenserver-in-virtualbox/

  • K - I'll try checking the logs after I get off work. – ubomb May 5 '14 at 14:15
1

Fixed by legacy booting

I was just having the same problem on my Intel NUC. The system was installed to boot as EFI and legacy booting was completely disabled in BIOS.

After installing xen-hypervisor, I ran into the same reboot loop.

What fixed the problem for me was enabling legacy booting again, although the system is still booting via EFI and not even capable of booting to legacy.

  • Amazing! It solves my problem, too. – kiki_yu May 17 at 1:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.