15

I've upgraded system from 13.10 to 14.04 LTS Now I need downgrade from Subversion 1.8 to Subversion 1.7, because formats 1.7 vs 1.8 are different and I can not access to svn repo of my team.

I've failed to compile svn from sources: a lot of dependencies, strange errors.

I can not understand why svn has not been packed into standalone deb package. I'm sure there are a lot of people that need precisely one svn version and do not need forced svn upgrade.

So, my question is: how can I switch to svn 1.7 from 1.8, staying at Ubuntu 14.04?

Update I've installed svn 1.7.9 on ubuntu 14.04 from source. Then I've installed svn 1.7.9 on ubuntu 14.04 as described below via apt-get and source.list manipulations

Both cases resulted with message:

The following repository access (RA) modules are available:

  • ra_svn : Module for accessing a repository using the svn network protocol.
    • handles 'svn' scheme
  • ra_local : Module for accessing a repository on local disk.
    • handles 'file' scheme

This message means that I can not access svn repository of my team, because http/https support is not installed.

Update2 I hate Subversion and Ubuntu. The second day I spend trying to compile Subversion 1.7 on Ubuntu 14.04 with http/https support. No result. I do not understand, why formats 1.7 and 1.8 of Subversion uncompatible. I hate Subversion developers.

I do not understand, why the http/https support is absent in https://launchpad.net/ubuntu/trusty/amd64/subversion/1.7.14-1ubuntu2 https://launchpad.net/ubuntu/trusty/amd64/libsvn1/1.7.14-1ubuntu2

Is it too difficult to give me ONLY ONE deb package, that I can install and forget about configuration?

I thought it'd take me for maximum 10 minutes: sudo apt-get install svn-1.7

But I spend my time configuring neon and serf and trying to fit for conditions of that I don't what.

  • Welcome to Ask Ubuntu. Please, could you put some of your time to read What should I do when someone answers my question? – Sylvain Pineau Apr 25 '14 at 14:41
  • I’m very sorry that things didn’t went quite as you expected. I tested it and my svn supports http and https. If you compiled and installed svn from source you most likely screwed up your installation. Compiling from source is ok, but installing without using the package manger is ALWAYS a BAD idea. The files of your compiled svn most likely interfer with the ones you installed via apt-get. You can only purge everything that has to do with svn from your computer (i.e. try to uninstall the compiled svn) and then follow the instructions in my answer. – Wauzl Apr 28 '14 at 18:40
  • SVN should be downward compatible according to the developers. Instead of downgrading your SVN version I would take a look at why you cannot connect to the old version server? – Requist Dec 17 '14 at 19:07
20

In order to expand Sylvain Pineaus answer a bit: I had the same problem as OP and I solved it like this:

I added the following lines at the end of /etc/apt/sources.list:

# REMEMBER TO DELETE THIS AFTER SVN 1.7 is installed
deb http://extras.ubuntu.com/ubuntu saucy main
deb http://de.archive.ubuntu.com/ubuntu/ saucy main universe restricted multiverse

Now remove the svn packages with version 1.8

sudo apt-get remove subversion libsvn1

update the sources

sudo apt-get update

and install the correct versions

sudo apt-get install subversion=1.7.9-1+nmu6ubuntu3 libsvn1=1.7.9-1+nmu6ubuntu3

Now we need to fix the version of the packages by

echo subversion hold | sudo dpkg --set-selections
echo libsvn1 hold | sudo dpkg --set-selections
echo libserf1 hold | sudo dpkg --set-selections

The libserf1 is needed by subversion or libsvn1 and is now (in 14.04) called libserf-1-1, I guess.

Now remove the lines of /etc/apt/sources.list that were added and update the sources once again (just to be sure)

sudo apt-get update
  • Hi, Wauzl. I've installed svn, but have not access via http/https. svn up returns "svn: E170000: Unrecognized URL scheme for" – user273083 Apr 28 '14 at 12:07
  • Never the less, thanks a lot for your detailed comment. – user273083 Apr 28 '14 at 12:08
  • 1
    @Wauzl, 1.7.9-1+nmu6ubuntu3 not found. – hiway Aug 1 '14 at 12:52
  • I would recommend using pkgs.org/search/subversion to download the 3 packages manually, its faster than futzing with the sources.list – kevinf Aug 27 '14 at 15:05
  • This answer is no longer working for me either unfortunately. I am Ubuntu 14.04 – thatidiotguy Aug 6 '15 at 13:29
9

I'm building on top of other answers here, but this is a script that seemed to work for Trusty 14.04:

# remove old versions
sudo apt-get remove subversion libsvn1 libserf1
# add Wandisco's Subversion maintenance package
wget -q -O - http://opensource.wandisco.com/wandisco-debian.gpg | sudo apt-key add -
sudo sh -c 'echo "deb http://opensource.wandisco.com/debian/ wheezy svn17" > /etc/apt/sources.list.d/wandisco-subversion.list'
sudo apt-get update
# install the version provided by Wandisco
sudo apt-get install subversion=1.7.22-1+WANdisco libsvn1=1.7.22-1+WANdisco
# make sure they don't get automatically upgraded to the latest
echo subversion hold | sudo dpkg --set-selections
echo libsvn1 hold | sudo dpkg --set-selections
echo libserf1 hold | sudo dpkg --set-selections
3

I have the same issue where an update upgraded my subversion from 1.7.x to 1.8.x and it seems non trivial to re-install 1.7 back.

My compromise was to use svnkit, a java implementation of subversion from what I can make of it. http://svnkit.com/download.php

So I still have subversion 1.8 installed but v1.7 of svnkit.

Slow but I can live with this.

Why downgrade, you ask?

My version of intellij (12.x) doesnt play nice with 1.8.x

2

Ok, I've solved by downloading https://launchpad.net/ubuntu/trusty/i386/subversion/1.7.14-1ubuntu2 and https://launchpad.net/ubuntu/trusty/i386/libsvn1/1.7.14-1ubuntu2

Sorry for the trouble.

  • You can mark the question as solved, since you have figured it out. – No Time Jun 16 '14 at 15:41
2

Had the same Problem on Ubuntu 14.04, but on 64 instead of 32 Bit. Remove default version 1.8:

sudo apt-get remove --purge libsvn1
sudo apt-get remove --purge subversion

Download and install version 1.7 (.../amd64/... instead of .../i386/...)

libsvn1: https://launchpad.net/ubuntu/trusty/amd64/libsvn1/1.7.14-1ubuntu2

subversion: https://launchpad.net/ubuntu/trusty/amd64/subversion/1.7.14-1ubuntu2

1

There's an existing/accepted answer to downgrade from 1.7 to 1.6 that you could use.

In your case just update (temporarily) the sources.list file not with precise but saucy.

Once done, don't forget to lock the version with:

echo subversion hold | sudo dpkg --set-selections
0

It's probably this bug, related to client certificate authentication and renegotiation?

But when will it be fixed?!? It is lying around for more than half a year.

Unfortunately there was a similar issue in 12.04.

So, svn+ssl-reneg+client-cert is extremely bad tested. :(

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.