9

I've just upgraded my distribution from 13.10 to 14.04, which seems to have broken global keyboard shortcuts.

They are still present in the "Keyboard settings" as before. Although media keys are affected, so are other global shortcuts like Ctrl+Alt+T for Terminal. Other keyboard shortcuts work at an application level still, however.

I am also currently using Gnome Shell as my desktop environment, although the Alt+F2 shortcut for shell commands still seems to work.

Does anyone know of how this could have been caused?

3

It seams to be a bug, see https://bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/1224732

On my laptop, they are two ways to bypass :

  1. my custom shortcut works if I use a more simple key binding. For example, Ctrl+Alt+ESC does not work, but SUPER+K works.

  2. use an alternative way to create a custom command with the CompizConfig Settings Manager launched with ccsm > Commands. Then create your key binding.

Remark in the both solution, my key binding Ctrl+Alt+ESC doest not work, but SUPER+K works. I think some key binding can not be used anymore.

| improve this answer | |
  • Using Compiz's "Commands" worked for me. – Tyler Collier Jan 4 '16 at 0:21
1

Same problem with Ubuntu 14.04, got fixed after forcibly upgrading gnome from 3.10 (stable) to 3.12 (staging)

sudo add-apt-repository ppa:gnome3-team/gnome3-staging
sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get install gnome-shell ubuntu-gnome-desktop
# reboot

By the time you're reading this 3.12 might be the stable version, so check first:

gnome-shell --version
#=> GNOME Shell 3.12.2
| improve this answer | |
  • 3
    I tried to check my gnome-shell version with the latter command, but got The program 'gnome-shell' is currently not installed. Could that really be the case? I'm on a regular install of Ubuntu 14.04. – Brian Z Oct 4 '14 at 4:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.