Mouse gets discovered. Although, it doesn't pair.

/var/log/syslog:

Apr 23 10:05:15 xavier bluetoothd[9873]: No agent available for request type 0
Apr 23 10:05:15 xavier bluetoothd[9873]: btd_event_request_pin: Operation not permitted
Apr 23 10:05:15 xavier bluetoothd[9873]: Connection refused (111)

It's worth saying that:

  • Keyboard has paired and it's working just fine though;
  • Mouse used to work just fine in Ubuntu 12.04, and 13, and it works when I reboot on Mac;

This is the hci device.

$ hcitool dev
Devices:
  hci0 E0:F8:47:3A:3F:47

How to get it working?

  • did you report this as a bug? I got the same issue and this solved it and using pin 0000 – user291995 Jun 9 '14 at 18:07
  • Thanks for converting that question?! Anyhow, I reported this as a bug here, please do this next time to improve things for everyone :) : bugs.launchpad.net/ubuntu/+source/bluez/+bug/1328260 If you are affected, please mark yourself as affected to help fix this bug. Thank you! – user291995 Jun 9 '14 at 20:47
up vote 29 down vote accepted

Problem was I didn't have an agent registered. Normally UI should do it. A quick solution is to run:

bluez-simple-agent

Do not background the process with the ampersand (&). The program will output Agent registered. Then, try to pair it again using the Bluetooth settings in system settings.

After you begin adding the mouse, you will be prompted for the PIN on the terminal. The PIN for the Apple Magic Mouse is 0000; type this in and press Enter. Your mouse should successfully pair back in the Bluetooth settings window.

After it has successfully paired, you can close the terminal window and end the bluez-simple-agent process without affecting your mouse's connectivity. Thanks to Szymon Janc.

  • This worked for me after hours of messing around with bluetooth managers. Thanks. – bleeves Jul 28 '14 at 11:21
  • It worked after doing some magic. Thanks – ilciavo Feb 15 '16 at 11:32
  • Sad day: dbus.exceptions.DBusException: org.bluez.Error.NoSuchAdapter: No such adapter – Jacksonkr Mar 3 '16 at 0:03

protected by Community Sep 16 '14 at 11:46

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.