0

Recently, I've run into a strange problem with Ubuntu Gnome. I installed 14.04 last Saturday and everything was fine. However, I woke up one morning to find my Asus HDMI monitor saying "VGA No Signal." This didn't make any sense, since I never changed its display settings. I ended up changing it back to HDMI using its hardware buttons.

However, my trouble didn't end there. Now, every time I move windows (even minimizing) on that specific monitor (I have two monitors), the desktop in the background will flicker with images of every frame when the window moved.

This does not occur on my other display, and did not occur on install. I never changed my graphics drivers, either. I tried disabling and re-enabling the monitor from the settings manager, but it was not fixed. Does anyone have a solution to my problem. This seems specific to Ubuntu, since the flickering only happens on the desktop, I just can't figure out why.

1 Answer 1

0

Maybe you have run into a similar problem described here.

The last commentor has the same issue I have, which I think is similar to yours.

I had the same problem (if the multi-monitor setup wasn't saved after reboot).

After startup - instead of auto-starting with a reset command you open up a terminal cmd+alt+t

Then enter:

xrandr --output LVDS --pos 1920x0 --output CRT1 --pos 0x0

(Where your monitor names and the positions are replaced by your specific settings)

Then the framebuffer will not occur.

More information here: http://bernaerts.dyndns.org/linux/74-ubuntu/309-ubuntu-dual-display-monitor-position-lost

I hope that there will be a better solution! ;-)

Edit:

I managed to delay the autostart of Gnome with the "X-GNOME-Autostart-Delay" property:

1. Create a new file "xrandr.sh" in /home/yourUserName/.config/monitors with the contents of your xrandr command (look above) and make it executeable:

#!/bin/bash

xrandr --output VGA-0 --pos 1920x0 --output DVI-I-1 --pos 0x30
exit

2. Create a new file "monitors.desktop" in /home/yourUserName/autostart with following contents:

[Desktop Entry]
Type=Application
Exec=/home/yourUserName/.config/monitors/xrandr.sh
Hidden=false
NoDisplay=false
X-GNOME-Autostart-enabled=true
X-GNOME-Autostart-Delay=05
Name[de_AT]=Bildschirme
Name=Monitors
Comment[de_AT]=Stellt die Bildschirme richtig ein
Comment=Sets the correct monitor setup

Now the xrandr script autostarts with 5 seconds delay and the flickering does not occure!

Note: The "[de_AT]" properties are optional!

1
  • the update of Gnome 3.14 promises to fix this issue (remembering multi monitor setups) Sep 25, 2014 at 4:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .