Is there a way to disable compiz effects for just one window type or application?

I use the alt + mouse click shortcut to move windows and I like it, but when I use inkscape I cannot use any options of the application that use alt because compiz immediately grabs the alt and puts me in window movement mode. I think this is a bad design, applications should be able to override this behavior if they need to....

Anyways is there a way to do it?



It's not possible. Gamers have been dealing with this topic for some time.

Furthermore, moving windows by using Alt+click isn't a feature of only Compiz. Metacity, the default window manager in GNOME (and hence the fallback when Compiz is disabled), does just the same thing.

Looking back to your original reason for wanting to do this, one workaround would be to use the "Windows" key instead of Alt:

  • Change the setting at System -> Preferences -> Windows -> Movement Key

You can also choose to disable the feature entirely:

  • If you're using Compiz, open CompizConfig Setting Manager and disable the "Initiate Window Move" binding for the "Move Window plugin".
  • If you're using Metacity, run gconf-editor and set /apps/metacity/general/mouse_button_modifier to be blank.

It seems to me, though, that the most appropriate solution would be to change Inkscape's behavior:

  • The Inkscape FAQ describes the modifications you will have to make to one of Inkscape's configuration files.

I don't know if there is a way to disable the behaviour for a specific window, but you could change the key biding to Super + Click instead.

  • Yeah, might as well do that... I doubt any application will use the super key.. though we never know. – levesque Sep 21 '10 at 23:38
  • 10 years necro-bump: I have to point out for any compiz fans remaining (all 14 of us) that this is by far the most sensible approach. The only gotcha is that unlike Super+Key bindings, on Mate (and likely anything gnome based, but I'm not sure), the release of the Super key _will_ fire up the start menu box. You can cancel that easily with a another Super click. – tgm1024--Monica was mistreated Nov 26 '20 at 15:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.