5

I would like to run SoulseekQT. However unfortunately one of the dependencies is libmng1, which is no more included in Trusty. sudo apt-get install libmng.so.1 or libmng1 or libmng1:i386 in Trusty (14.04) no more available. Do you have any idea how to solve this conflict?
I mean is it really sure that libmng1 is excluded? Could I use libmng2 somehow instead? If not, could I somehow rebuild libmng1 for Trusty? Or do I have to downgrade back to Saucy (13.10)?

5 Answers 5

4

When the major version number of a library changes, it usually means the library is no longer compatible with the previous interface that it provided. Previous versions of Ubuntu had libmng1, but now libmng2 is provided and all Ubuntu packages in 14.04 have been rebuilt to use libmng.so.2. Third-party applications, as in this case, may need to be rebuilt to work with the updated libraries in 14.04. Until then, you can try installing the library package from the most recent Ubuntu release that had libmng1.

To install libmng1 alongside libmng2, first find the most recent version in supported Ubuntu releases from http://packages.ubuntu.com/libmng1. Then download and install the appropriate package for your architecture. For example:

wget http://archive.ubuntu.com/ubuntu/pool/main/libm/libmng/libmng1_1.0.10-3build1_i386.deb
sudo dpkg -i libmng1_1.0.10-3build1_i386.deb

Note that you will not get updates for this package since it is not in the Ubuntu 14.04 repositories.

Of course a far better solution would be to get the application developers to provide a new build of SoulseekQt that works with Ubuntu 14.04 now that it is released.

1
2

I tried several solutions, but the one that worked for me is to link it to an existing library in Ubuntu. First find the library:

$ locate libmng.so.2
/usr/lib/x86_64-linux-gnu/libmng.so.2
/usr/lib/x86_64-linux-gnu/libmng.so.2.0.2

Then make a symbolic link to this:

$ ln -s /usr/lib/x86_64-linux-gnu/libmng.so.2 /usr/lib/x86_64-linux-gnu/libmng.so.1

Good luck!

1

Installation from source

sudo apt-get install liblcms1-dev
wget http://prdownloads.sourceforge.net/libmng/lm010010.zip
unzip lm010010.zip
cd libmng
# MANUAL: edit `makefiles/makefile.linux` to add `-fPIC` to `CFLAGS` 
make -f makefiles/makefile.linux
sudo make -f makefiles/makefile.linux install
# MANUAL: add /usr/local/lib to your search path: http://unix.stackexchange.com/questions/67781/use-shared-libraries-in-usr-local-lib

Tested on Ubuntu 14.04.

0

After reading mtmiller's explanations, I have tried his code but I get a dependancy problem. So, as indicated in http://packages.ubuntu.com/saucy/i386/libmng1/download, instead of dowloading the requested file and doing the installation manually, I add the french mirrored repository "deb http://fr.archive.ubuntu.com/ubuntu saucy main" in Synaptic and then I installed the libmng1 package from Synaptic.

0

good! I also have problem. but

sudo ln -s /usr/lib/x86_64-linux-gnu/libmng.so.2 /usr/lib/x86_64-linux-gnu/libmng.so.1

is a solver to me thank you saber. I think ubuntu 16.04 is not compatible with webot 7.4.1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .